Bug 205316 - Upgrade org.apache.commons.lang
Upgrade org.apache.commons.lang
Status: RESOLVED WONTFIX
Product: projects
Classification: Unclassified
Component: Generic Projects UI
7.1
All All
: P3 (vote)
: TBD
Assigned To: Tomas Stupka
issues@projects
: ARCH
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-19 18:09 UTC by Jesse Glick
Modified: 2016-07-07 08:39 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2011-11-19 18:09:29 UTC
We currently ship 2.4 (despite the license file which claims 2.3). 2.6 is marked on their website as the latest "legacy" release, and 3.1 is recommended.

For bdf59cfe5ce5 I really needed a Pair<T,U> class. I do not really want to stuff this generic language utility into org.openide.util when org.apache.commons.lang3.tuple.ImmutablePair (@since 3.0) already does what I want.

2.x and 3.x use different package names; probably they could both be bundled?
Comment 1 Tomas Stupka 2012-12-05 16:32:12 UTC
> 2.x and 3.x use different package names; probably they could both be bundled?
org.apache.commons.lang 2.4 is shipped with mylyn which wouldn't work with >= 3.0 so no motivation in issue tracking to upgrade.

seems to be possible to bundle both packages, but the owner of #bdf59cfe5ce5 should decide
Comment 2 Milos Kleint 2012-12-11 14:06:10 UTC
I'm slightly confused here. bdf59cfe5ce5 doesn't require currently commons-lang3. But it could be rewritten to use it?

is this issue about creating new module org.apache.commons.lang3 ? with a different codenamebase from the current org.apache.commons.lang module?
Comment 3 Milos Kleint 2012-12-12 10:13:02 UTC
moving to enhancement until convinced otherwise, I'm not seeing a defect here.
Comment 4 Martin Balin 2016-07-07 08:39:26 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo