Bug 205289 - JIRA plugin cannot be installed from 7.1 UC
JIRA plugin cannot be installed from 7.1 UC
Status: VERIFIED FIXED
Product: updatecenters
Classification: Unclassified
Component: Stable
7.1
PC Mac OS X
: P1 (vote)
: 7.1
Assigned To: pgebauer
Autoupdate Masters
: 71_HR_FIX
: 202554 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-18 12:20 UTC by Tomas Danek
Modified: 2011-11-23 12:46 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Danek 2011-11-18 12:20:47 UTC
Product Version: NetBeans IDE 7.1 RC1 (Build 201111171527)
Java: 1.6.0_29; Java HotSpot(TM) 64-Bit Server VM 20.4-b02-402
System: Mac OS X version 10.7.2 running on x86_64; MacRoman; en_US (nb)
User directory: /Users/tomas/.netbeans/7.1rc1
Cache directory: /Users/tomas/.netbeans/7.1rc1/var/cache
--------------------------
probably same problem as issue 202554, needs to be solved for 7.1

UC: 
http://updates.netbeans.org/netbeans/updates/7.1/uc/final/certified/catalog.xml.gz
Comment 1 pgebauer 2011-11-18 12:40:21 UTC
Yes, I aware of it. The file catalog.xml has to be processed manually for jar-files. NBMs work fine as in the past. I will change it.
Comment 2 pgebauer 2011-11-18 15:22:40 UTC
It should be fixed.
Comment 3 Marian Mirilovic 2011-11-19 08:29:51 UTC
*** Bug 202554 has been marked as a duplicate of this bug. ***
Comment 4 Tomas Danek 2011-11-20 22:09:04 UTC
Jira now can be installed, thanks. But i guess we still need to solve somehow "unsignes modules problem"?! for 7.1 FCS (http://netbeans.org/bugzilla/show_bug.cgi?id=202756)
Comment 5 pgebauer 2011-11-21 08:20:34 UTC
(In reply to comment #4)
> Jira now can be installed, thanks. But i guess we still need to solve somehow
> "unsignes modules problem"?! for 7.1 FCS
> (http://netbeans.org/bugzilla/show_bug.cgi?id=202756)

If you want to sign them, please agree with a JIRA plugin owner to pack jar files into NBMs. It solves two things at ones. I will be able to sign modules and the file catalog.xml will not need to be processed manually.
Comment 6 Tomas Danek 2011-11-21 08:43:13 UTC
FYI: I get after installing jira http://statistics.netbeans.org/analytics/exception.do?id=544380.
Seems to me problem like in module itself, not problem of missing items in catalog.
Comment 7 Tomas Danek 2011-11-21 08:45:24 UTC
corresponding issue if here: http://netbeans.org/bugzilla/show_bug.cgi?id=205019
Comment 8 Tomas Danek 2011-11-21 10:38:55 UTC
I read the dialog more carefully and it says that plugins are signed, but not trusted. (sorry for misleading previous info).  

(In reply to comment #5)
> (In reply to comment #4)
> > Jira now can be installed, thanks. But i guess we still need to solve somehow
> > "unsignes modules problem"?! for 7.1 FCS
> > (http://netbeans.org/bugzilla/show_bug.cgi?id=202756)
> 
> If you want to sign them, please agree with a JIRA plugin owner to pack jar
> files into NBMs. It solves two things at ones. I will be able to sign modules
> and the file catalog.xml will not need to be processed manually.
Comment 9 Tomas Danek 2011-11-23 12:46:13 UTC
verified original problem - Jira can be installed from UC, but opened issue 205476 for tracking untrusted certificate problem.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo