Bug 205268 - [71cat] NullPointerException at org.netbeans.modules.projectapi.LazyLookupProviders$1$1.beforeLookup
[71cat] NullPointerException at org.netbeans.modules.projectapi.LazyLookupPro...
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
7.1
All All
: P3 (vote)
: 7.2
Assigned To: Jesse Glick
issues@projects
EXCEPTIONS_REPORT
: THREAD
: 211112 (view as bug list)
Depends on: 205533
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-18 08:25 UTC by tim_sa
Modified: 2012-04-13 00:11 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.46 KB, text/plain)
2011-11-18 08:25 UTC, tim_sa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tim_sa 2011-11-18 08:25:34 UTC
Build: NetBeans IDE Dev (Build 201111160600)
VM: Java HotSpot(TM) Client VM, 21.1-b02, Java(TM) SE Runtime Environment, 1.7.0_01-b08
OS: Windows 7

User Comments:
GUEST: abrindo o programa.




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.projectapi.LazyLookupProviders$1$1.beforeLookup(LazyLookupProviders.java:80)
   at org.openide.util.lookup.ProxyLookup$R.myBeforeLookup(ProxyLookup.java:672)
   at org.openide.util.lookup.ProxyLookup$R.computeResult(ProxyLookup.java:526)
   at org.openide.util.lookup.ProxyLookup$R.allInstances(ProxyLookup.java:497)
   at org.openide.util.lookup.ProxyLookup$R.collectFires(ProxyLookup.java:634)
   at org.openide.util.lookup.ProxyLookup.setLookups(ProxyLookup.java:168)
Comment 1 tim_sa 2011-11-18 08:25:39 UTC
Created attachment 113304 [details]
stacktrace
Comment 2 Jesse Glick 2011-11-18 16:08:06 UTC
Is it possible for there to be concurrent calls to beforeLookup on a single ProxyLookup? They really need to be synchronized since this is used for lazy initialization of lookup contents that needs to be at most once per lookup. From looking at the code it seems that synchronizing on the ProxyLookup object ought to be safe, so I will try that, though I am surprising that it is not already called with that monitor held.
Comment 3 Jesse Glick 2011-11-18 16:10:01 UTC
core-main #821eb8a8e979
Comment 4 Quality Engineering 2011-11-20 16:37:28 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/821eb8a8e979
User: Jesse Glick <jglick@netbeans.org>
Log: #205268: [71cat] NullPointerException at org.netbeans.modules.projectapi.LazyLookupProviders$1$1.beforeLookup
Comment 5 Jesse Glick 2012-04-13 00:11:39 UTC
*** Bug 211112 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo