Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 204963 - [71cat] ClassCastException: org.openide.text.UndoRedoManager cannot be cast to org.netbeans.modules.properties.PropertiesEditorSupport$UndoRedoStampFlagManager
[71cat] ClassCastException: org.openide.text.UndoRedoManager cannot be cast t...
Status: RESOLVED FIXED
Product: utilities
Classification: Unclassified
Component: Properties
7.1
All All
: P3 (vote)
: 7.1
Assigned To: Jan Peska
issues@utilities
EXCEPTIONS_REPORT
:
: 205106 205113 205197 (view as bug list)
Depends on:
Blocks: 21237
  Show dependency treegraph
 
Reported: 2011-11-10 23:19 UTC by alied
Modified: 2011-11-20 22:10 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.26 KB, text/plain)
2011-11-10 23:19 UTC, alied
Details
stacktrace (2.26 KB, text/plain)
2011-11-10 23:58 UTC, alied
Details

Note You need to log in before you can comment on or make changes to this bug.
Description alied 2011-11-10 23:19:02 UTC
Build: NetBeans IDE Dev (Build 201111090600)
VM: Java HotSpot(TM) Client VM, 21.1-b02, Java(TM) SE Runtime Environment, 1.7.0_01-b08
OS: Windows XP

User Comments:
alied: I'm not quite sure how I got this exception.
reporting because i saw the red error icon.
Next time I'll pay more attention.




Stacktrace: 
java.lang.ClassCastException: org.openide.text.UndoRedoManager cannot be cast to org.netbeans.modules.properties.PropertiesEditorSupport$UndoRedoStampFlagManager
   at org.netbeans.modules.properties.PropertiesOpen$CompoundUndoRedoManager.getNextUndo(PropertiesOpen.java:1493)
   at org.netbeans.modules.properties.PropertiesOpen$CompoundUndoRedoManager.getUndoPresentationName(PropertiesOpen.java:1629)
   at org.openide.actions.UndoRedoAction.getName(UndoRedoAction.java:190)
   at org.openide.actions.UndoRedoAction.run(UndoRedoAction.java:158)
   at org.openide.actions.UndoRedoAction.propertyChange(UndoRedoAction.java:237)
   at org.openide.util.WeakListenerImpl$PropertyChange.propertyChange(WeakListenerImpl.java:196)
Comment 1 alied 2011-11-10 23:19:06 UTC
Created attachment 113101 [details]
stacktrace
Comment 2 alied 2011-11-10 23:58:18 UTC
Created attachment 113103 [details]
stacktrace
Comment 3 err 2011-11-14 15:21:27 UTC
Notice bug 199700 which is loosely related since it is another problem that is caused by property editor not using CES's undo-redo manager as a base class.
Comment 4 Miloslav Metelka 2011-11-14 18:00:33 UTC
http://hg.netbeans.org/jet-main/rev/253c5d98d9fa
Comment 5 Miloslav Metelka 2011-11-15 08:23:12 UTC
*** Bug 205113 has been marked as a duplicate of this bug. ***
Comment 6 Quality Engineering 2011-11-16 15:51:00 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/253c5d98d9fa
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #204963 - ClassCastException: org.openide.text.UndoRedoManager cannot be cast to org.netbeans.modules.properties.PropertiesEditorSupport$UndoRedoStampFlagManager
Comment 7 Miloslav Metelka 2011-11-16 18:30:31 UTC
*** Bug 205106 has been marked as a duplicate of this bug. ***
Comment 8 Miloslav Metelka 2011-11-20 22:10:01 UTC
*** Bug 205197 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo