Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 204849 - [71cat] [71cat] AssertionError: Should be a folder: D:\projects\TutorialCalculator\build\web\WEB-INF\classes\calculator@c9e33b13:751176
[71cat] [71cat] AssertionError: Should be a folder: D:\projects\TutorialCalcu...
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Filesystems
7.1
All All
: P4 (vote)
: 7.2
Assigned To: Jaroslav Tulach
issues@platform
EXCEPTIONS_REPORT
:
: 203384 204243 204982 206176 206178 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-08 16:25 UTC by muellermi
Modified: 2011-12-15 10:37 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (609 bytes, text/plain)
2011-11-08 16:25 UTC, muellermi
Details
stacktrace (640 bytes, text/plain)
2011-11-22 14:24 UTC, MackSix
Details

Note You need to log in before you can comment on or make changes to this bug.
Description muellermi 2011-11-08 16:25:27 UTC
This bug was originally marked as duplicate of bug 202413, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201111070600)
VM: Java HotSpot(TM) Client VM, 21.1-b02, Java(TM) SE Runtime Environment, 1.7.0_01-b08
OS: Windows XP

User Comments:
MackSix: Opened a project and double clicked a java source file in the Porjects window to view it.
I had just created a new project under the directory C:\Users\Mark\Documents\NetBeansProjects\FireFly\. I deleted that project and then opened up another project in a directory called C:\Users\Mark\Documents\NetBeansProjects\FireListners\ with an identical Main.java source file. I do not know why it thinks this Main.java file should be in FireFly when I deleted the project and this Main.java is in FireListeners. The reason for the duplicate is I was trying to reproduce a problem(s) I see frequently with refactoring after changing project, package or source file names.  I had renamed package and then project in the deleted project and saw an exception box pop up and then it went away before I could do anything, but the refactoring worked. I think the instability of the refactoring could have set this problem up to occur.
Additionally, the problems that I happen when refactoring are: 1. the project in a state where the main class can not be located and I have to restart NetBeans to get it to work. 2. project.properties is not being updated when the project name is changed forcing me to manually edit it so that the jar file is compiled with the correct project name.

muellermi: editing Servlet

MackSix: Renamed a Project with Renaming of Folder. Then renamed Package with Refactoring while a JFrame Form file is open.




Stacktrace: 
java.lang.AssertionError: Should be a folder: D:\projects\TutorialCalculator\build\web\WEB-INF\classes\calculator@c9e33b13:751176
   at org.netbeans.modules.masterfs.watcher.Watcher$Ext.unregister(Watcher.java:253)
   at org.netbeans.modules.masterfs.watcher.Watcher.unregister(Watcher.java:134)
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.BaseFileObj.removeFileChangeListener(BaseFileObj.java:508)
   at org.openide.filesystems.FileUtil$Holder.run(FileUtil.java:554)
   at org.openide.util.lookup.implspi.ActiveQueue$Impl.run(ActiveQueue.java:109)
   at java.lang.Thread.run(Thread.java:722)
Comment 1 muellermi 2011-11-08 16:25:30 UTC
Created attachment 113009 [details]
stacktrace
Comment 2 Jaroslav Tulach 2011-11-21 14:10:09 UTC
*** Bug 204982 has been marked as a duplicate of this bug. ***
Comment 3 Jaroslav Tulach 2011-11-21 14:10:19 UTC
*** Bug 203384 has been marked as a duplicate of this bug. ***
Comment 4 Jaroslav Tulach 2011-11-21 14:10:28 UTC
*** Bug 204243 has been marked as a duplicate of this bug. ***
Comment 5 Jaroslav Tulach 2011-11-21 14:10:39 UTC
*** Bug 204911 has been marked as a duplicate of this bug. ***
Comment 6 MackSix 2011-11-22 14:24:51 UTC
Created attachment 113415 [details]
stacktrace

Trying to create New Master/Detail Form in a new Java Project. I was on step 3 of creaation (Master Table) and selected the sample database connection in the "Database Connection" combo box and this AssertionError happened.
Comment 7 MackSix 2011-11-22 14:41:16 UTC
Product Version: NetBeans IDE 7.1 RC1 (Build 201111171527)
Java: 1.7.0_01; Java HotSpot(TM) Client VM 21.1-b02
System: Windows Vista version 6.0 running on x86; Cp1252; en_US (nb)
Comment 8 Jaroslav Tulach 2011-12-07 18:42:04 UTC
ergonomics#cb9885d47ea3
Comment 9 Quality Engineering 2011-12-09 12:11:04 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/cb9885d47ea3
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #204849: Maybe the folder has been deleted meanwhile
Comment 10 Jaroslav Tulach 2011-12-15 10:34:19 UTC
*** Bug 206176 has been marked as a duplicate of this bug. ***
Comment 11 Jaroslav Tulach 2011-12-15 10:37:27 UTC
*** Bug 206178 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo