Bug 204819 - CodeCompletion took 9963 ms.
CodeCompletion took 9963 ms.
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Completion & Templates
7.1
All All
: P3 (vote)
: 7.1
Assigned To: Dusan Balek
issues@editor
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-08 09:49 UTC by kabasky
Modified: 2011-11-11 15:36 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (29.81 KB, application/nps)
2011-11-08 09:49 UTC, kabasky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kabasky 2011-11-08 09:49:44 UTC
This bug was originally marked as duplicate of bug 194969, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.1 Beta (Build 201109252201)
VM: Java HotSpot(TM) Client VM, 21.0-b17, Java(TM) SE Runtime Environment, 1.7.0-b147
OS: Windows 7

User Comments:
kabasky: I was just creating a PieChart.Data object



Maximum slowness yet reported was 9963 ms, average is 9963
Comment 1 kabasky 2011-11-08 09:49:49 UTC
Created attachment 112988 [details]
nps snapshot
Comment 2 Dusan Balek 2011-11-10 10:41:16 UTC
Fixed in jet-main.

http://hg.netbeans.org/jet-main/rev/22b702c2a19d
Comment 3 Quality Engineering 2011-11-11 15:36:25 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/22b702c2a19d
User: Dusan Balek <dbalek@netbeans.org>
Log: Issue #204819: CodeCompletion took 9963 ms - fixed.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo