Bug 204450 - Rewrite actions to use TypingHooks SPI
Rewrite actions to use TypingHooks SPI
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Actions/Menu/Toolbar
7.1
PC Linux
: P2 (vote)
: 7.2
Assigned To: Milutin Kristofic
issues@editor
:
Depends on: 208981
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-31 13:00 UTC by Miloslav Metelka
Modified: 2012-03-07 18:12 UTC (History)
2 users (show)

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Miloslav Metelka 2011-10-31 13:00:45 UTC
Actions in BaseKit and NbEditorKit as well as their extensions in language supporting modules should be rewritten to use TypingHooks SPI.
Comment 1 Milutin Kristofic 2012-01-09 12:55:22 UTC
Javakit http://hg.netbeans.org/jet-main/rev/83e32d743168
Comment 2 Quality Engineering 2012-01-12 16:01:38 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/83e32d743168
User: Milutin Kristofic <mkristofic@netbeans.org>
Log: #204450 - Rewrite actions to use TypingHooks SPI
Comment 3 David Strupl 2012-02-24 09:24:38 UTC
I think this one can be closed, correct?
Comment 4 Quality Engineering 2012-02-28 10:51:43 UTC
Integrated into 'main-golden', will be available in build *201202280400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/e9a6ebb16ec5
User: Milutin Kristofic <mkristofic@netbeans.org>
Log: #204450 - Rewrite actions to use TypingHooks SPI
Comment 5 Vladimir Voskresensky 2012-02-28 10:58:44 UTC
Is it correct to use X.Y.1 as version of module in trunk?
Comment 6 Petr Jiricka 2012-02-28 13:11:46 UTC
I see that org.netbeans.modules.javascript.editing.JsKeystrokeHandlerTest started to fail in the build where this change appeared: http://bertram-tst.netbeans.org:8080/job/javaee/3801/testReport/

Could this failure be caused by this change?
Comment 7 Milutin Kristofic 2012-02-28 13:45:33 UTC
It is probably because change in Bug #208653 I am investigating it.
Comment 8 Milutin Kristofic 2012-02-28 15:40:28 UTC
Petr, It's fixed in Bug #208931
Comment 9 Petr Jiricka 2012-02-28 17:02:45 UTC
Thanks; it sounds like it would be useful to add unit tests for this problem.
Comment 10 Miloslav Metelka 2012-03-05 15:26:58 UTC
(In reply to comment #5)
> Is it correct to use X.Y.1 as version of module in trunk?

Definitely not. Milutin please fix ASAP. Thanks.
Comment 12 Quality Engineering 2012-03-07 18:12:45 UTC
Integrated into 'main-golden', will be available in build *201203071105* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/0b85ac57ac99
User: Milutin Kristofic <mkristofic@netbeans.org>
Log: #204450 - Rewrite actions to use TypingHooks SPI - fix versions


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo