Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 204345 - Quickly reopen last tab
Quickly reopen last tab
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Window System
7.0.1
PC Linux
: P2 with 9 votes (vote)
: 7.3
Assigned To: Stanislav Aubrecht
issues@platform
72patch1-verified
:
: 203872 212595 (view as bug list)
Depends on:
Blocks: 211167
  Show dependency treegraph
 
Reported: 2011-10-27 23:01 UTC by samirfor
Modified: 2018-09-01 11:17 UTC (History)
9 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description samirfor 2011-10-27 23:01:01 UTC
I wanted the Netbeans IDE had the same functionality of Chrome and Firefox browsers to open the last tab quickly with the content intact.

This need arose because sometimes closing a tab accidentally.
Comment 1 Deldadam 2012-01-16 22:03:03 UTC
Closing a tab accidently means closing an edited file, that can be reopened 'quickly' using the File -> Open Recent File submenu :)

If you speak about another tabs (not file related ones) then they can be reopened the normal Window menu.

Cheers.
Comment 2 Miloslav Metelka 2012-02-23 10:12:16 UTC
I would personally like such action too and have a Ctrl+Shift+T shortcut for it (like in a browser).
Reassigning to window system for evaluation.
Comment 3 Stanislav Aubrecht 2012-04-26 07:54:06 UTC
*** Bug 203872 has been marked as a duplicate of this bug. ***
Comment 4 Stanislav Aubrecht 2012-05-17 07:54:00 UTC
*** Bug 212594 has been marked as a duplicate of this bug. ***
Comment 5 Stanislav Aubrecht 2012-05-17 07:55:39 UTC
*** Bug 212595 has been marked as a duplicate of this bug. ***
Comment 6 mienamoo 2012-06-06 09:55:05 UTC
Would it be possible to add this option to the context menu for the tabs? It makes sense to me to put it there together with Close and Close All and Close Other. :)
Comment 7 ulfzibis 2012-06-06 10:32:38 UTC
Please have a look how it works by "Tab Mix Plus" Addon on Firefox.
There are 2 actions in the context menu:
- Open closed tab
- Recent closed tabs -> [Submenu with last X closed tabs]

Additionally you can have "Close all left/right tabs": bug 185733
Comment 8 schkovich 2012-06-06 12:23:18 UTC
I like the most original and Miroslav Metelka (comment #2) proposals: ctrl+shift+t will open new tab displaying preview boxes of recently closed files.
Comment 9 Michel Graciano 2012-06-06 13:34:55 UTC
(In reply to comment #2)
> I would personally like such action too and have a Ctrl+Shift+T shortcut for it
> (like in a browser).
> Reassigning to window system for evaluation.

I totally agree with it.
Comment 10 samirfor 2012-06-06 14:57:30 UTC
(In reply to comment #2)
> I would personally like such action too and have a Ctrl+Shift+T shortcut for it
> (like in a browser).
> Reassigning to window system for evaluation.

That's exactly what I want.
I would love to have this feature in Netbeans.
Comment 11 erusev 2012-06-06 15:02:37 UTC
Me too.

Btw, it'd have been great if we had a way to "upvote" instead of having to write that we agree with a suggestion.

Here's what it could look like:
http://sublimetext.userecho.com/
Comment 12 Jiri Kovalsky 2012-06-06 15:31:39 UTC
Then why don't you simply vote for this bug by clicking "vote" link next to its priority? Scroll up this page to see it.
Comment 13 erusev 2012-06-06 15:34:24 UTC
Because I didn't realize that I could and that's not my fault. The UI is bad.
Comment 14 Jiri Kovalsky 2012-06-06 15:37:47 UTC
I agree that it's not too straightforward. :(
Comment 15 Stanislav Aubrecht 2012-06-27 10:51:34 UTC
core-main 17758528e893

The default keyboard shortcut is Ctrl+Alt+T as Ctrl+Shift+T is already taken for Go To Test actions.
Comment 16 Quality Engineering 2012-06-28 04:55:22 UTC
Integrated into 'main-golden', will be available in build *201206280002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/17758528e893
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #204345 - keyboard shortcut to reopen recently closed file
Comment 17 Michel Graciano 2012-06-29 14:20:31 UTC
Thanks for the fix, it is really helpful. Anyway, I have verified it at trunk and the default shortcut is not friendly for Linux distros, since many of them use Ctrl + Alt + T for Terminal. I don't know if it is a issue for another OSes but it could be a issue for Linux users.
Comment 18 Stanislav Aubrecht 2012-06-29 16:47:49 UTC
Well, there's a shortage of available shortcuts in NetBeans. Perhaps I can trade Ctrl+Shift+T shortcut with Go To Test action...
Comment 19 Michel Graciano 2012-06-29 17:06:54 UTC
(In reply to comment #18)
> Well, there's a shortage of available shortcuts in NetBeans.

Yes, I am aware of it :(

I really have no idea what a good shortcut it could be, maybe the UI engineer could help us on this?
Comment 20 Stanislav Aubrecht 2012-07-02 09:11:35 UTC
Any hints from UI team?
Comment 21 mienamoo 2012-07-11 06:15:43 UTC
IMHO it would be best if the keyboard shortcut is the same as people are already used to in most browsers (Ctrl+Shift+T). And I believe that this action would be used much more frequently than Go To Test, making the swap in shortcuts worthwhile. :)
Comment 22 everflux 2012-07-11 10:38:58 UTC
I strongly disagree. Go to test/go to class under test is one of the most important shortcuts for me.
Besides it is the same in intellij, so transition from intellij to netbeans - or vice versa - is easier keeping the shortcuts semantics.

The usage of <ctrl><alt>T for a terminal is really a pity. Perhaps <ctrl><alt><shift>T could be used instead?
Comment 23 matthies 2012-07-11 14:44:07 UTC
Ctrl+Alt shortcuts should be avoided altogether. One reason is that it collides with AltGr (cf. http://blogs.msdn.com/b/oldnewthing/archive/2004/03/29/101121.aspx), another is that it's generally used for global system-level shortcuts (e.g. http://blogs.msdn.com/b/oldnewthing/archive/2004/03/29/101121.aspx#101243).
Comment 24 cimprr 2012-08-03 06:39:19 UTC
I'm looking forward for this feature too!
Comment 25 Tomas Danek 2012-08-27 13:55:14 UTC
verified in trunk Product Version: NetBeans IDE Dev (Build 201208170001)
Java: 1.7.0_06; Java HotSpot(TM) 64-Bit Server VM 23.2-b09
System: Mac OS X version 10.8 running on x86_64; US-ASCII; en_US (nb)
User directory: /Users/tomas/Library/Application Support/NetBeans/dev
Cache directory: /Users/tomas/Library/Caches/NetBeans/dev

..please proceed with backport of fix.
Comment 26 Stanislav Aubrecht 2012-08-29 08:57:26 UTC
transplanted to release72 branch as c398583e5305
Comment 27 Quality Engineering 2012-09-01 11:04:29 UTC
Integrated into 'releases', will be available in build *201209010822* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/c398583e5305
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #204345 - keyboard shortcut to reopen recently closed file
(transplanted from 17758528e89303eb1702d8960fbb6bc857ec552f)
Comment 28 lastneox 2015-02-19 16:24:22 UTC
(In reply to samirfor from comment #0)
> I wanted the Netbeans IDE had the same functionality of Chrome and Firefox
> browsers to open the last tab quickly with the content intact.
> 
> This need arose because sometimes closing a tab accidentally.

I need this to
Comment 29 Geertjan Wielenga 2015-02-19 17:35:19 UTC
Watch the movie: https://www.youtube.com/watch?v=Mp0m9x2dpU4 It shows "Open Recent File" in action, as well as "Last Edit".
Comment 30 russkiy 2018-09-01 11:17:04 UTC
"Open Recent File" doesn't work for SQL tabs


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo