Bug 204223 - Integrate copy/paste history plugin into NetBeans IDE sources
Integrate copy/paste history plugin into NetBeans IDE sources
Status: RESOLVED DUPLICATE of bug 56401
Product: editor
Classification: Unclassified
Component: Actions/Menu/Toolbar
-S1S-
PC Linux
: P2 (vote)
: TBD
Assigned To: Miloslav Metelka
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-25 15:12 UTC by Geertjan Wielenga
Modified: 2012-07-17 13:19 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Geertjan Wielenga 2011-10-25 15:52:54 UTC
I'm sure the NetBeans engineers would take the plugin as the basis of their own work, i.e., they wouldn't take it as-is, but look at it and take from it what makes sense and enhance it in any way necessary.
Comment 2 Michel Graciano 2011-10-25 16:02:56 UTC
I really would like to see it integrated at the IDE. I am really honored to see this proposal :)

Most of the plugin was developed based on users wishes, including some patches I had received. All the options were requested by users and IMHO make sense, so I guess if you really wish to integrate it, I will be happy to delivery all the details I have about what users expect from it. There are some request I had no time to delivery at the plugin and no patches were developed, maybe we can address those in the future, but personally speaking the plugin had attended my needs for years now and I am really happy with the current simple features.
Comment 3 Milutin Kristofic 2012-07-17 12:54:07 UTC
I would like to implement some clipboard history implementation in 7.3. If we want to use this plugin, there should be some license changes in plugin (it's LGPL). Still investigating in Bug #56401

*** This bug has been marked as a duplicate of bug 56401 ***
Comment 4 Michel Graciano 2012-07-17 13:19:09 UTC
(In reply to comment #3)
> I would like to implement some clipboard history implementation in 7.3. If we
> want to use this plugin, there should be some license changes in plugin (it's
> LGPL). Still investigating in Bug #56401
> 

If you need any change at the plugin side, just let me know. I have no objections about licensing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo