Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 20421 - XSL code completion
XSL code completion
Status: RESOLVED FIXED
Product: xml
Classification: Unclassified
Component: Text-Edit
3.x
All All
: P4 with 2 votes (vote)
: 3.x
Assigned To: Asgeir Asgeirsson
issues@xml
plan
:
: 22598 (view as bug list)
Depends on: 14296
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-11 09:23 UTC by Remco Hulshoff
Modified: 2007-09-25 01:33 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Remco Hulshoff 2002-02-11 09:23:49 UTC
I would like to see the xml module delivered with the complete xsl syntax. To 
me this means that when i type "<xsl:" the autocompletion already knows all 
the valid entities en when i type (or choose) "<xsl:template" it offers a list 
of valid attributes for this entity.

I am available to do the grunt work on this. i.e. typing all the entities and 
their attributes in some java file.
Comment 1 _ pkuzel 2002-02-11 09:59:17 UTC
Cool Medusa. If you want to focus just on XSLT it is pretty simple to
achieve it. You simply implement org.netbeans.modules.xml.spi.model
GrammarQuery SPI.

Once implemented, it can be plugged in. Unfortunately GrammarQuery
plug-in mechanism is currently hardcoded in
org.netbeans.modules.xml.text.completion.XMLCompletionQuery. I can
modify it.

More generally, universal namespace aware XML Schema completition
would be better solution, but it is rather complex.

You are welcome, ask any questions
Comment 2 _ pkuzel 2002-04-17 17:05:28 UTC
In 3.4 timeframe we have to rely on "specify fake DTD" workaround. The
workaround is simple: both XSLT and XHTML DTDs are avalilable for
public and parametrizable.
Comment 3 _ pkuzel 2002-06-03 12:26:32 UTC
Let these are considered while planning next release.
Comment 4 Marek Grummich 2002-07-19 16:57:26 UTC
Target milestone was changed from not determined to TBD
Comment 5 _ pkuzel 2002-08-14 16:56:57 UTC
Feature positively influences user 
productivity.  
Comment 6 _ pkuzel 2002-08-14 16:57:06 UTC
Feature positively influences user 
productivity.  
Comment 7 _ pkuzel 2002-08-14 17:01:08 UTC
*** Issue 22598 has been marked as a duplicate of this issue. ***
Comment 8 _ pkuzel 2002-08-14 17:05:34 UTC
Asgeir is working on it and his implementation 
offers some advanced features such as Xpath 
completion in select attributes, etc. 
 
You can check it out in 4.0 development 
versions. 
Comment 9 Asgeir Asgeirsson 2002-10-09 17:20:19 UTC
This is implemented by the 
org.netbeans.modules.xsl.grammar.XSLGrammarQuery class 
which is located in the xml/xsl module.
Comment 10 _ pkuzel 2003-02-06 10:38:35 UTC
This functionality is targeted to  be a part of NetBeans 3.5 standard release.
At this moment it is necessary to stabilize it fully, pass I18N checks, pass
A11Y checks, pass UI checks and properly document it.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo