Bug 204172 - Deadlock between XDMModel.getDocument and XDMModel.flushDocument
Deadlock between XDMModel.getDocument and XDMModel.flushDocument
Status: RESOLVED DUPLICATE of bug 202352
Product: projects
Classification: Unclassified
Component: Maven
7.1
PC Linux
: P3 (vote)
: 7.2
Assigned To: Milos Kleint
issues@projects
: THREAD
: 211928 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-24 17:13 UTC by Jesse Glick
Modified: 2012-05-03 08:24 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Trimmed thread dump (9.83 KB, text/plain)
2011-10-24 17:13 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2011-10-24 17:13:10 UTC
Created attachment 112380 [details]
Trimmed thread dump

Not obvious to me from thread dump what is at fault. Something presumably has the read lock on the document (AnnotationView?). Does a caller need to manually acquire a document write lock before calling AbstractModel.endTransaction? Threading assumptions of XAM/XDM are not clearly documented that I know of.
Comment 1 Milos Kleint 2012-05-02 06:55:34 UTC
*** Bug 211928 has been marked as a duplicate of this bug. ***
Comment 2 Milos Kleint 2012-05-03 08:24:26 UTC
appears to be a duplicate of 202352 (in the sense that the fix for that bug fixed this one, not that they are the same problem)

*** This bug has been marked as a duplicate of bug 202352 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo