Bug 204022 - Git pull/push wizard is annoying and disrupts the workflow
Git pull/push wizard is annoying and disrupts the workflow
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Git
7.0.1
PC Windows 7 x64
: P2 with 1 vote (vote)
: 7.3
Assigned To: Ondrej Vrabec
issues@versioncontrol
: PLAN
: 206042 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-20 14:53 UTC by coops
Modified: 2013-09-16 08:17 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description coops 2011-10-20 14:53:11 UTC
A normal developer (like me) can be forced to pull/push 30 times a day. The current wizard dialog solution is NOT ACCEPTABLE. This is something it should just do in the background without interrupting me. Currently I have to click through lots of options which it fails to remember (like what branch to use... protip: if I have only 1 branch (like 99% of all project does) what do you think I will do?). Also it locks up the IDE while it connects.

Git pull/push is not implemented in my eyes because the UI is unusable.

Preferably you should solve this with a new solution called "sync" which does BOTH push and pull in the background with preconfigured options (without interrupting me).

Usability 101: A Wizard should NEVER be the default way to interact with a function. They are a nice addon for beginners though.
Comment 1 piksel8 2011-12-06 23:35:14 UTC
*** Bug 206042 has been marked as a duplicate of this bug. ***
Comment 2 alex_andrascu 2012-07-29 17:08:58 UTC
Any update on this ? I would be really interested in this functionality? A toolbar like Eclipse has maybe?
Comment 3 Ondrej Vrabec 2012-08-07 11:41:27 UTC
> Any update on this ? I would be really interested in this functionality? A toolbar like Eclipse has maybe?
i don't use eclipse, so i have no idea what you're referring to. Can you attach a screenshot or a link to the appropriate section in EGit userguide?
Comment 4 Ondrej Vrabec 2012-08-13 17:47:10 UTC
let's add three actions: Git -> Remote -> Fetch/Pull from and Push to Upstream
These actions try to guess what branches to push or fetch and if every needed setting is identified then perform the operation silently in the background
Comment 5 Ondrej Vrabec 2012-08-13 17:49:37 UTC
fix: http://hg.netbeans.org/core-main/rev/9d39ad16e9e7
Comment 6 Quality Engineering 2012-08-15 01:40:45 UTC
Integrated into 'main-golden', will be available in build *201208150001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/9d39ad16e9e7
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: #204022 - Git pull/push wizard is annoying and disrupts the workflow
Comment 7 digitman222 2013-09-16 08:11:39 UTC
I wouldn't say the current way of doing this is user friendly either. E.g you still have to browse through 3-4 right click options. Can we just add a simple button to the toolbar which will push to the same branch / repository that you've selected (if no repo selected, then the first time it can open the current dialog for selecting it), or add a keyboard shortcut which does this?
Comment 8 Ondrej Vrabec 2013-09-16 08:17:07 UTC
(In reply to digitman222 from comment #7)
> I wouldn't say the current way of doing this is user friendly either. E.g
> you still have to browse through 3-4 right click options.
I don't understand what 3-4 right click options you mean

> Can we just add a simple button to the toolbar which will push to the same branch / repository
see #233582.
> or add a keyboard shortcut which does this?
Nothing prevents you from doing so. Tools -> Options -> Keymap | Push to Upstream action, you can choose any shortcut you wish.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo