Bug 203877 - LowPerformance took 5854 ms.
LowPerformance took 5854 ms.
Status: RESOLVED WONTFIX
Product: java
Classification: Unclassified
Component: Editor
7.0
All All
: P3 (vote)
: 7.2
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-18 08:12 UTC by lolo_101
Modified: 2012-05-30 14:30 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (95.80 KB, application/nps)
2011-10-18 08:13 UTC, lolo_101
Details
nps snapshot (134.03 KB, application/nps)
2012-05-09 07:44 UTC, lolo_101
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lolo_101 2011-10-18 08:12:56 UTC
Build: NetBeans IDE Dev (Build 201110160600)
VM: Java HotSpot(TM) Client VM, 20.1-b02, Java(TM) SE Runtime Environment, 1.6.0_26-b03
OS: Windows XP
Maximum slowness yet reported was 5854 ms, average is 4098
Comment 1 lolo_101 2011-10-18 08:13:01 UTC
Created attachment 112159 [details]
nps snapshot
Comment 2 lolo_101 2012-05-09 07:44:57 UTC
Created attachment 119190 [details]
nps snapshot

starting up
Comment 3 Miloslav Metelka 2012-05-30 12:37:17 UTC
Only evaluating report 578467 (build 120501).
The TextLayout creation is expensive and there's no way how to overcome that.
There is JavaTokenId$1.embedding() related classloading but the only chance to eliminate this is IMHO a more thorough warm-up (reassigning to java for final decision whether to do it or not).
Comment 4 Dusan Balek 2012-05-30 14:30:13 UTC
As can be seen from the attached snapshots, JavaTokenId$1.embedding() is blocked inside class loading which seems to be slow due to heavy IO load caused by some Maven project opening and running svn.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo