Bug 203752 - Support for SVN version 1.7.0
Support for SVN version 1.7.0
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Subversion
7.1
PC Windows 7 x64
: P1 with 7 votes (vote)
: 7.2
Assigned To: Ondrej Vrabec
issues@versioncontrol
: PLAN
: 204134 204339 205308 205630 206350 206364 207926 208016 (view as bug list)
Depends on: 204148 206620 207270 207746 207910 208017
Blocks: 207751
  Show dependency treegraph
 
Reported: 2011-10-14 20:04 UTC by jasondrums
Modified: 2012-10-15 03:40 UTC (History)
16 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jasondrums 2011-10-14 20:04:01 UTC
Product Version = NetBeans IDE Dev (Build 201110120600)
Operating System = Windows XP version 5.1 running on x86
Java; VM; Vendor = 1.6.0_25
Runtime = Java HotSpot(TM) Client VM 20.0-b11

Netbeans reports that the client being used is too old. The Subversion module might need to be updated to support SVN release 1.7.0.
Comment 1 Tomas Stupka 2011-10-17 15:12:54 UTC
for now use the commandline client as a fallback 
-J-DsvnClientAdapterFactory=commandline
Comment 2 Ondrej Vrabec 2011-10-24 09:25:52 UTC
*** Bug 204134 has been marked as a duplicate of this bug. ***
Comment 3 Ondrej Vrabec 2011-10-24 09:36:06 UTC
First we should make the fallback to the commandline client (complicated -J-DsvnClientAdapterFactory=commandline setup) automatic: tracked as bug #204148
Comment 5 Ondrej Vrabec 2011-10-30 19:39:43 UTC
*** Bug 204339 has been marked as a duplicate of this bug. ***
Comment 6 Ondrej Vrabec 2011-11-18 20:38:33 UTC
*** Bug 205308 has been marked as a duplicate of this bug. ***
Comment 7 Ondrej Vrabec 2011-11-30 09:58:04 UTC
*** Bug 205630 has been marked as a duplicate of this bug. ***
Comment 8 Ondrej Vrabec 2011-12-14 13:22:00 UTC
*** Bug 206350 has been marked as a duplicate of this bug. ***
Comment 9 Ondrej Vrabec 2011-12-19 10:53:58 UTC
*** Bug 206364 has been marked as a duplicate of this bug. ***
Comment 10 Marian Mirilovic 2012-01-10 08:47:55 UTC
*** Bug 206964 has been marked as a duplicate of this bug. ***
Comment 11 fommil 2012-02-02 11:35:51 UTC
*** Bug 207926 has been marked as a duplicate of this bug. ***
Comment 12 fommil 2012-02-02 11:36:40 UTC
Please back port a fix for 7.0.1 - 7.1 is not quite ready for OS X yet (fullscreen mode trouble).
Comment 13 fommil 2012-02-02 12:02:41 UTC
Hmm, not sure if I should be spawning a new issue for this, but "Netbeans SVN commandline" is not behaving the same way as "SVN from the command line" for me.

I have all my certificates and passwords entered into the SVN configuration (works fine from the command line), but running via Netbeans in commandline mode gives me:


INFO [org.netbeans.modules.subversion]: cli: ERROR "svn: OPTIONS of 'https://REMOVED': Server certificate verification failed: issuer is not trusted (https://REMOVED)"
INFO [org.netbeans.modules.subversion]: cli: ERROR "svn: OPTIONS of 'https://REMOVED': authorization failed: Could not authenticate to server: rejected Basic challenge (https://REMOVED)"


I'm running svn 1.6.16 bundled with OS X Lion and Netbeans 7.0.1.

What else needs to be added to the config to ensure that the command line SVN is really being called correctly?
Comment 14 Ondrej Vrabec 2012-02-02 12:25:55 UTC
(In reply to comment #13)
Copying the accepted server certificates from ~/.subversion/config/auth/svn.ssl.server to ~/.netbeans/VERSION/config/svn/config/auth/svn.ssl.server could help.
Comment 15 Ondrej Vrabec 2012-02-02 13:32:24 UTC
*** Bug 208016 has been marked as a duplicate of this bug. ***
Comment 16 fommil 2012-02-08 12:27:31 UTC
In reply to comment 14, I still get a prompt for the username/password if I do that. This means that the commandline SVN option is still using the NB bundled configurations - if I'm using the command line SVN client then I want to be using the svn configuration options from ~/.subversion which will access passwords stored in my OS X Keychain, etc etc.
Comment 17 Ondrej Vrabec 2012-03-21 16:53:16 UTC
fixed in trunk, svnkit and javahl support upgraded to 1.7
Comment 18 fommil 2012-05-10 21:11:29 UTC
This fix didn't hit the 7.1.2 patches - any chance of that happening?
Comment 19 Ondrej Vrabec 2012-05-11 07:44:11 UTC
(In reply to comment #18)
> This fix didn't hit the 7.1.2 patches - any chance of that happening?
No, sorry.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo