Bug 203645 - Visual Designers aren't generating any code
Visual Designers aren't generating any code
Status: RESOLVED DUPLICATE of bug 200270
Product: editor
Classification: Unclassified
Component: Formatting & Indentation
7.1
PC Windows XP x64
: P1 (vote)
: TBD
Assigned To: Dusan Balek
issues@editor
: ERGONOMICS, REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-13 12:29 UTC by Stepan Zebra
Modified: 2011-10-20 07:00 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
messages.log (60.32 KB, text/plain)
2011-10-19 08:16 UTC, Stepan Zebra
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stepan Zebra 2011-10-13 12:29:09 UTC
Product Version: NetBeans IDE Dev (Build 201110120600)
Java: 1.7.0; Java HotSpot(TM) Client VM 21.0-b17
System: Windows 7 version 6.1 running on x86; Cp1252; en_US (nb)

No source code is generated in Visual Design and Game Builder classes, when some elements are added to them using their designers. NPEs are then thrown when trying to access the elements added in the designers, switching to the source and saving the changes.
Comment 1 Stepan Zebra 2011-10-19 08:16:11 UTC
Created attachment 112206 [details]
messages.log

java.lang.NullPointerException
	at org.netbeans.modules.editor.indent.TaskHandler$MimeItem.indentRegions(TaskHandler.java:435)
	at org.netbeans.modules.editor.indent.spi.Context.indentRegions(Context.java:258)
	at org.netbeans.modules.java.source.save.Reformatter.reformat(Reformatter.java:140)
	at org.netbeans.modules.editor.indent.TaskHandler$MimeItem.runTask(TaskHandler.java:548)
	at org.netbeans.modules.editor.indent.TaskHandler.runTasks(TaskHandler.java:316)
	at org.netbeans.modules.editor.indent.IndentImpl.reformat(IndentImpl.java:357)
	at org.netbeans.modules.editor.indent.api.Reformat.reformat(Reformat.java:154)
	at org.netbeans.modules.editor.impl.DefaultIndentEngine$WriterImpl.flush(DefaultIndentEngine.java:156)
...
Comment 2 David Strupl 2011-10-19 08:35:51 UTC
Dusane, can you please help Anton with this? Thanks, David.
Comment 3 Anton Chechel 2011-10-19 08:56:08 UTC
reassigning to editor
Comment 4 Dusan Balek 2011-10-20 07:00:15 UTC
Already reported.

*** This bug has been marked as a duplicate of bug 200270 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo