Bug 203568 - Broken Code semantic completion for background property with multiple values
Broken Code semantic completion for background property with multiple values
Status: VERIFIED FIXED
Product: web
Classification: Unclassified
Component: CSS Visual Tools
7.1
PC Windows XP
: P1 (vote)
: 7.1
Assigned To: Marek Fukala
issues@javaee
: 71_HR_FIX
: 203064 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-12 06:55 UTC by Vladimir Riha
Modified: 2012-01-02 10:38 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Riha 2011-10-12 06:55:41 UTC
Steps to reproduce:
- in css file, paste following:

div{
background: #ff6666
}

- type space after the color definition and invoke cc => nothing is offered and "," is autocompleted

Also:
- paste 

div{
background: center 
}

- again type space after center and invoke cc => items only from background-position are offered (so no color, image etc. and also it completes already used properties/values).

Product Version: NetBeans IDE Dev (Build 201110110600)
Java: 1.7.0_01; Java HotSpot(TM) Client VM 21.1-b02
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)
Comment 1 Marek Fukala 2011-11-22 14:34:56 UTC
*** Bug 203064 has been marked as a duplicate of this bug. ***
Comment 2 Marek Fukala 2011-11-28 15:53:45 UTC
changeset:   207506:6d47f0669a2c
date:        Mon Nov 28 16:48:01 2011 +0100
summary:     #203568 - complete grammar resolver and alternatives analyzer rewrite, implemented aggregation of properties with same name, fixed many bugs and typos in the properties definition files (though it is very likely there are more), disabled an obsolete module, added plenty of unit tests. There are still some known problems with the resolved/analyzer though they seem to be minor. Performance is worser than in the previous implementation - mainly due to the parsing mechanism of ambiguous grammars. There's a plenty of room for performance optimalizations though.

Now the question is if the QE wants the fix in the 7.1. Even if there's lots of tests on almost everything affected still the change is quite huge and may possibly introduce some regressions. 

If it was up to me, I'd disable the css values error checks in 7.1 (so we at least do not bother users with false errors) and leave the completion untouched.

Then in 7.1.1 I'll integrate this fix with some improvements after some more thorough QE verification.

What do you think? Vlado? Mariane? Petre?
Comment 3 Marian Mirilovic 2011-11-28 21:00:10 UTC
My personal opinion : looking at the changeset http://hg.netbeans.org/web-main/rev/6d47f0669a2c it's huge and I do not want to do that during HR 

What we can do, is to integrate it into trunk, test it properly and fix in patch 1 for 7.1
Comment 4 Vladimir Riha 2011-11-29 07:22:07 UTC
I agree, this can wait to 7.1.1
Comment 5 Petr Jiricka 2011-11-29 08:39:24 UTC
> If it was up to me, I'd disable the css values error checks in 7.1 (so we at
> least do not bother users with false errors) and leave the completion untouched.

Sounds good.
Comment 6 Marek Fukala 2011-11-29 11:48:51 UTC
Vlado, can you assess the current 7.1 situation in the css property values checking on some real word cases and let me know whether you consider it as so broken so it should be disabled or you do feel we can keep it and fix properly in 7.1.1?? Thank you in advance.
Comment 7 Vladimir Riha 2011-12-01 09:51:56 UTC
I've tried some css files with css3 features and it shows some errors and a lot of "unexpected value token..." warnings so I guess it should be disabled for 7.1.
Comment 8 Quality Engineering 2011-12-01 12:08:32 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/6d47f0669a2c
User: Marek Fukala <mfukala@netbeans.org>
Log: #203568 - complete grammar resolver and alternatives analyzer rewrite, implemented aggregation of properties with same name, fixed many bugs and typos in the properties definition files (though it is very likely there are more), disabled an obsolete module, added plenty of unit tests. There are still some known problems with the resolved/analyzer though they seem to be minor. Performance is worser than in the previous implementation - mainly due to the parsing mechanism of ambiguous grammars. There's a plenty of room for performance optimalizations though.
Comment 9 Marek Fukala 2011-12-02 10:27:58 UTC
So I'm going to disable the CSS property values error checks in release71 branch...
Comment 10 Marek Fukala 2011-12-02 10:36:13 UTC
7.1 fix => P1
Comment 11 Marian Mirilovic 2011-12-02 12:02:30 UTC
Ok, integrate into release71 ASAP please
Comment 12 Marek Fukala 2011-12-02 12:25:46 UTC
changeset:   214691:3b976b6dcd62
branch:      release71
summary:     #203568 - disabling css property values error checks in netbeans 7.1

http://hg.netbeans.org/releases/rev/3b976b6dcd62
Comment 13 Marek Fukala 2011-12-02 12:48:34 UTC
Upon an agreement with Marian I've created new Bug 205843 so we can track the proper fix integration into 7.1.1 release
Comment 14 Quality Engineering 2011-12-03 08:00:56 UTC
Integrated into 'releases'
Changeset: http://hg.netbeans.org/releases/rev/3b976b6dcd62
User: Marek Fukala <mfukala@netbeans.org>
Log: #203568 - disabling css property values error checks in netbeans 7.1
Comment 15 Vladimir Riha 2012-01-02 10:38:41 UTC
verified initial problem in bug's description. More comments in issue #205843

Product Version: NetBeans IDE Dev (Build 201201010601)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo