Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 203564 - NullPointerException at org.netbeans.modules.dlight.management.api.impl.DataStorageManager.getDataStorage
NullPointerException at org.netbeans.modules.dlight.management.api.impl.DataS...
Status: RESOLVED DUPLICATE of bug 187469
Product: cnd
Classification: Unclassified
Component: D-Light
7.1
All All
: P3 (vote)
: TBD
Assigned To: Maria Tishkova
dlight-issues@cnd
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-12 05:48 UTC by Vladimir Kvashin
Modified: 2011-10-12 10:34 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.03 KB, text/plain)
2011-10-12 05:48 UTC, Vladimir Kvashin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Kvashin 2011-10-12 05:48:07 UTC
Build: Code Analyzer 2011/09/13 cd796d70881a
VM: Java HotSpot(TM) Client VM, 17.0-b16, Java(TM) SE Runtime Environment, 1.6.0_21-b06
OS: SunOS

User Comments:
vkvashin: configured mysql with -xanalyze=code flag, built it, launched code analyzer for mysqld - got an NPE




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.dlight.management.api.impl.DataStorageManager.getDataStorage(DataStorageManager.java:378)
   at org.netbeans.modules.dlight.management.api.impl.DataStorageManager.getDataStorage(DataStorageManager.java:349)
   at org.netbeans.modules.dlight.management.api.impl.DataStorageManager.getDataStorageFor(DataStorageManager.java:470)
   at org.netbeans.modules.dlight.management.api.impl.DataStorageManager.getDataStoragesFor(DataStorageManager.java:146)
   at org.netbeans.modules.dlight.management.api.DLightSession.prepareContext(DLightSession.java:731)
   at org.netbeans.modules.dlight.management.api.DLightSession.access$400(DLightSession.java:106)
Comment 1 Vladimir Kvashin 2011-10-12 05:48:12 UTC
Created attachment 111902 [details]
stacktrace
Comment 2 Vladimir Voskresensky 2011-10-12 10:34:19 UTC

*** This bug has been marked as a duplicate of bug 187469 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo