Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 203503 - [71cat] folder in project tree empty
[71cat] folder in project tree empty
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Project
7.1
PC Windows XP
: P3 (vote)
: 7.1
Assigned To: Tomas Zezula
issues@java
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-11 12:50 UTC by muellermi
Modified: 2011-11-14 14:47 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
messages.log (96.25 KB, text/plain)
2011-10-11 12:50 UTC, muellermi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description muellermi 2011-10-11 12:50:12 UTC
Product Version = NetBeans IDE Dev (Build 201110100600)
Operating System = Windows XP version 5.1 running on x86
Java; VM; Vendor = 1.7.0
Runtime = Java HotSpot(TM) Client VM 21.0-b17

After working for a while, the source folder of the project tree became empty. Trying to navigate with Shift-Ctrl-1 selected the source folder but did not display any sub folder (packages displayed as tree).
In the files tree, all sources had been available. Only restart of NB helped to get a proper function again.
By now, I don't know how to reproduce this bug, it happened only once. I'll file messages.log.
Comment 1 muellermi 2011-10-11 12:50:53 UTC
Created attachment 111845 [details]
messages.log
Comment 2 Jaroslav Tulach 2011-10-14 19:57:53 UTC
I am not sure what exactly can be your problem, but I see in the log a lot of warnings from java.project.support.ui.TreeRootNode$PackageFilterChildren.copyNode

The support seems to be querying node.getLookup().lookup(DataObject.class) directly in AWT which is ineffective. I guess first of all the java.project.support.ui.TreeRootNode$PackageFilterChildren.copyNode should be rewritten and then we can speculate why your folder is empty (if you will be able to reproduce the problem then).
Comment 3 Tomas Zezula 2011-10-14 20:20:59 UTC
Doing node.getLookup().lookup(DataObject.class) may be inefficient (even I don't know why as these nodes are DataNodes which take the DO in constructor) but it should not have any effect on the fact that the nodes are not visible.
Comment 4 Tomas Zezula 2011-11-14 14:47:32 UTC
The warnings from java.project.support.ui.TreeRootNode$PackageFilterChildren.copyNode is fixed,
Fixed jet-main 002c73ed1b13.
The rest has nothing in common with TreeNode and cannot be reproduced.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo