Bug 203299 - Class redifinition after "Stop Profiling Classed below this Line" fails
Class redifinition after "Stop Profiling Classed below this Line" fails
Status: RESOLVED FIXED
Product: profiler
Classification: Unclassified
Component: Engine
7.1
All All
: P3 (vote)
: 7.3
Assigned To: Tomas Hurka
issues@profiler
: VISUALVM
: 224386 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-07 12:51 UTC by J Bachorik
Modified: 2013-07-04 06:56 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Log file (165.55 KB, text/plain)
2011-10-07 12:51 UTC, J Bachorik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description J Bachorik 2011-10-07 12:51:54 UTC
Created attachment 111656 [details]
Log file

1. Memory profile the Java2DDemo application with the following setings:
- Record both object creation and garbage collection
- Track every 10 objects allocations
- Record stack trace for allocations
2. Let the application run to collect some data
3. Open live results
4. Select java.lang.reflect.Method and from the popup menu choose "Stop Profiling Classes below this Line"
5. The class redefinition fails with JVMTI error 60

Attaching the log.
Comment 1 Tomas Hurka 2013-01-08 16:34:58 UTC
*** Bug 224386 has been marked as a duplicate of this bug. ***
Comment 2 Tomas Hurka 2013-01-08 19:15:22 UTC
Fixed in profiler-main

changeset:   243479:2670ed7ab40b
user:        Tomas Hurka <thurka@netbeans.org>
date:        Tue Jan 08 20:13:01 2013 +0100
summary:     bugfix #203299, reset various tables after clazz is written, but only for classes which do not have any saved method infos
Comment 3 Quality Engineering 2013-01-09 02:25:31 UTC
Integrated into 'main-golden', will be available in build *201301090001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/2670ed7ab40b
User: Tomas Hurka <thurka@netbeans.org>
Log: bugfix #203299, reset various tables after clazz is written, but only for classes which do not have any saved method infos


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo