Bug 20328 - Execute recipe (or jar) with spc in pathname throws exception
Execute recipe (or jar) with spc in pathname throws exception
Status: CLOSED FIXED
Product: obsolete
Classification: Unclassified
Component: jarpackager
-FFJ-
Other Other
: P3 (vote)
: -FFJ-
Assigned To: issues@obsolete
issues@obsolete
: SPACE_IN_PATH
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-08 10:48 UTC by Richard Malaschitz
Modified: 2003-07-01 10:01 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Malaschitz 2002-02-08 10:48:46 UTC
If .jar in recipe contains space (for example "c:\my files\try.jar" or "c:\userdir\my 
jar.jar") execute this jar throws exception:

-----------------------------------------------------------------------
java.util.zip.ZipException: The system 
cannot find the file specified
        at java.util.zip.ZipFile.open(Native Method)
        at 
java.util.zip.ZipFile.<init>(ZipFile.java:112)
        at 
java.util.jar.JarFile.<init>(JarFile.java:117)
        at 
java.util.jar.JarFile.<init>(JarFile.java:55)
Exception in thread "main" 
-----------------------------------------------------------------------
Jar file 
is properly compiled because I can run it:

java -jar "c:\my files\try.jar"
Comment 1 Milos Kleint 2002-03-27 15:06:12 UTC
is this the whole stacktrace?
Comment 2 Milos Kleint 2002-03-28 15:28:24 UTC
fixed in main trunk.
Comment 3 David Kaspar 2002-04-02 12:18:01 UTC
Verified
Comment 4 Martin Entlicher 2002-04-18 11:36:34 UTC
Merged into orion_fcs branch.
Comment 5 Jesse Glick 2002-05-10 18:02:53 UTC
SPACE_IN_PATH is a searchable keyword.
Comment 6 Milos Kleint 2002-06-18 14:45:12 UTC
*** Issue 24909 has been marked as a duplicate of this issue. ***
Comment 7 Quality Engineering 2003-07-01 09:59:48 UTC
Resolved for 3.4 or earlier, no new info since then -> closing.
Comment 8 Quality Engineering 2003-07-01 10:01:12 UTC
Resolved for 3.4 or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo