Bug 203233 - Can't run or debug project because it thinks scanning is running
Can't run or debug project because it thinks scanning is running
Status: RESOLVED DUPLICATE of bug 201617
Product: java
Classification: Unclassified
Component: Project
7.1
PC Linux
: P2 (vote)
: 7.1
Assigned To: Tomas Zezula
issues@java
: ERGONOMICS
: 203229 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-06 13:13 UTC by Petr Cyhelsky
Modified: 2011-10-10 15:03 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Cyhelsky 2011-10-06 13:13:09 UTC
Product Version: NetBeans IDE Dev (Build 20111006-8a7bee1acf3e)
Java: 1.6.0_22; OpenJDK 64-Bit Server VM 20.0-b11
System: Linux version 2.6.38-11-generic running on amd64; UTF-8; en_US (nb)

steps to reproduce:
have some previously created java project(anagram game) -> start full ide with ergonomics with clean userdir -> open the previously created project -> wait a long time to be absolutely sure all the scanning is finished -> try run, debug, etc.. -> wait for classpath scanning finish dialog pops and is there forever (because no classpath scanning to wait for is runnning)
Comment 1 Tomas Zezula 2011-10-06 14:26:52 UTC
>start full ide with ergonomics with clean userdir
And why are you reporting it on java/ project? :-)
Comment 2 Tomas Zezula 2011-10-06 14:36:04 UTC
Seems like just another 7.1 ergonomics issue. ProjectOpenHook.projectOpened - not called, services instantiated before layer is merged, .....
Comment 3 J Bachorik 2011-10-06 14:40:43 UTC
*** Bug 203229 has been marked as a duplicate of this bug. ***
Comment 4 Tomas Zezula 2011-10-10 15:03:02 UTC
In fact duplicate of issue #201617.
The POH is not called and no CPs are registered in GPR (so the java infrastructure does not know about the project) and also no scan was started so the java waits for the initial scan.
In addition to this Go To type, Symbol and other Java features does not work until you open the first java file and forces a scan.

Rollbacking fix of issue #200500 solves the problem.

*** This bug has been marked as a duplicate of bug 201617 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo