Bug 203232 - NPE in THAHintsProvider
NPE in THAHintsProvider
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: D-Light
7.1
All All
: P2 (vote)
: TBD
Assigned To: Vladimir Voskresensky
dlight-issues@cnd
CR_7097409, 701patch2-verified
:
: 199414 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-06 13:04 UTC by Vladimir Voskresensky
Modified: 2011-10-11 11:44 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
patch 3/3 (6.57 KB, patch)
2011-10-06 15:51 UTC, Vladimir Voskresensky
Details | Diff
patch 2/3 (3.35 KB, patch)
2011-10-06 15:52 UTC, Vladimir Voskresensky
Details | Diff
patch 1/3 (5.00 KB, patch)
2011-10-06 15:53 UTC, Vladimir Voskresensky
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Voskresensky 2011-10-06 13:04:29 UTC
from CR7097409
The reason is that
SourceFileInfo sourceFileInfo1 = dataProvider.getSourceFileInfo(call1);
returns null due to incorrect path translation in
org.netbeans.modules.dlight.perfan.lineinfo.impl.SSSourceFileInfoSupport
Comment 1 Vladimir Voskresensky 2011-10-06 15:51:14 UTC
Created attachment 111608 [details]
patch 3/3

correctly provide file paths
Comment 2 Vladimir Voskresensky 2011-10-06 15:52:04 UTC
Created attachment 111609 [details]
patch 2/3

use PathUtilities instead of java.io.File
Comment 3 Vladimir Voskresensky 2011-10-06 15:53:04 UTC
Created attachment 111610 [details]
patch 1/3

er_print can be null when storage is not created successfully due to any kind of exception => prevent NPE
Comment 4 Vladimir Voskresensky 2011-10-06 15:53:31 UTC
Andrew, I have prepared patch and split it by topics
Please, review.
Comment 5 Andrew Krasny 2011-10-06 16:34:35 UTC
I agree with proposed fixes.

2 small notes:
please do:
remove unneeded imports (java.io.File)
use Boolean.getBoolean() for FULL_REMOTE_KEY
Comment 6 Vladimir Voskresensky 2011-10-06 17:04:27 UTC
fixed on e**f
changeset:   204895:e300f50ac19c
branch:      release701_fixes
tag:         tip
user:        Vladimir Voskresensky <vv159170@netbeans.org>
date:        Thu Oct 06 20:59:09 2011 +0400
summary:     fixed #203232 NPE in THAHintsProvider

changeset:   204894:d84362715cc1
branch:      release701_fixes
user:        Vladimir Voskresensky <vv159170@netbeans.org>
date:        Thu Oct 06 20:57:55 2011 +0400
summary:     fixing #203232 NPE in THAHintsProvider

changeset:   204893:6f10c7a82d57
branch:      release701_fixes
user:        Vladimir Voskresensky <vv159170@netbeans.org>
date:        Thu Oct 06 20:56:58 2011 +0400
summary:     fixing #203232 NPE in THAHintsProvider
Comment 7 Alexander Pepin 2011-10-06 18:19:26 UTC
Checked in oss dev build #3383 in DD on Windows
NPE does not appear any more but navigation from stack still does not work (see CR 7097412).
Comment 8 Alexander Pepin 2011-10-06 18:22:19 UTC
it looks like the bug should be checked in oss dev build #3384
Comment 9 Alexander Pepin 2011-10-07 11:00:49 UTC
verified in oss dev build #3385 in DD on Windows
Comment 11 Quality Engineering 2011-10-07 17:36:04 UTC
Integrated into 'releases'
Changeset: http://hg.netbeans.org/releases/rev/6f10c7a82d57
User: Vladimir Voskresensky <vv159170@netbeans.org>
Log: fixing #203232 NPE in THAHintsProvider
- use PathUtilities instead of java.io.File
Comment 12 Vladimir Voskresensky 2011-10-11 10:12:41 UTC
*** Bug 199414 has been marked as a duplicate of this bug. ***
Comment 13 soldatov 2011-10-11 11:44:34 UTC
Verified in Oracle Solaris Studio 12.3 (2011/10/10)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo