Bug 203102 - Profiler metrics are not shown
Profiler metrics are not shown
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: D-Light
7.0.1
All All
: P2 (vote)
: 7.0.1
Assigned To: Andrew Krasny
dlight-issues@cnd
701patch2-verified, CR_7097502
: REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-04 21:25 UTC by Andrew Krasny
Modified: 2011-10-11 10:48 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Proposed patch (7.99 KB, patch)
2011-10-04 21:32 UTC, Andrew Krasny
Details | Diff
Take #2 (7.80 KB, patch)
2011-10-05 16:24 UTC, Andrew Krasny
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Krasny 2011-10-04 21:25:07 UTC
Profiler metrics are not displayed.
Steps to reproduce:

- create ProfilingDemo project
- choose DTrace Extended profiler configuration
- run the project
- call HotSpot details
- double-click on work_run_usrcpu function in the table

The same problem is with remote/full remote projects...
Comment 1 Andrew Krasny 2011-10-04 21:32:20 UTC
Created attachment 111487 [details]
Proposed patch

The problem is that again we have faced with the problem of different file mappings... 
The proposed solution is to use CndFileUtils to do the magic for translating paths... Note that this fix introduces a dependency on cnd.utils from dlight.annotation.support (for me it looks OK. But would like to hear from reviewers)..

With this fix following scenarios are covered (when QA will verify, please pay attention to this)

1. Local run => all files are annotated as expected and all of them are local
2. Remote run => all files are annotated as expected; system includes are remote; sources are local;
3. Full remote run => all files are annotated as expected; system includes are remote; sources are remote;
Comment 2 Vladimir Voskresensky 2011-10-05 16:03:10 UTC
(In reply to comment #1)
> Created an attachment (id=111487) [details]
> Proposed patch
> 
> The problem is that again we have faced with the problem of different file
> mappings... 
> The proposed solution is to use CndFileUtils to do the magic for translating
> paths... Note that this fix introduces a dependency on cnd.utils from
> dlight.annotation.support (for me it looks OK. But would like to hear from
> reviewers)..
It is not OK, but there are same methods in Remote API in FileSystemProvider
Comment 3 Andrew Krasny 2011-10-05 16:24:59 UTC
Created attachment 111551 [details]
Take #2

Right. Proposed fix now uses dlight.remote, so there is no dependency on cnd cluster.
Comment 4 Andrew Krasny 2011-10-05 16:58:47 UTC
pushed to e**f cs d7afff71717f
Comment 5 Vladimir Voskresensky 2011-10-05 17:04:29 UTC
Fix is correct and solves the issue
Comment 6 Alexander Pepin 2011-10-06 13:07:08 UTC
verified in OSS dev build #3381 in DD on Windows
Comment 7 Vladimir Voskresensky 2011-10-07 13:32:29 UTC
integrated
http://hg.netbeans.org/releases/rev/d7afff71717f
Comment 8 soldatov 2011-10-11 10:48:39 UTC
Verified in Oracle Solaris Studio 12.3 (2011/10/10)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo