Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 203078 - Provide way to run all tests in a package
Provide way to run all tests in a package
Status: RESOLVED DUPLICATE of bug 124313
Product: java
Classification: Unclassified
Component: JUnit
7.0.1
All All
: P3 with 1 vote (vote)
: TBD
Assigned To: Theofanis Oikonomou
junit-issues@java
:
: 223129 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-04 16:11 UTC by mjr_1974
Modified: 2013-09-04 14:56 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mjr_1974 2011-10-04 16:11:18 UTC
Product Version = NetBeans IDE 7.0.1 (Build 201107282000)
Operating System = Linux version 2.6.35-30-generic running on amd64
Java; VM; Vendor = 1.6.0_26
Runtime = Java HotSpot(TM) 64-Bit Server VM 20.1-b02

I think when a test package is selected in the Projects view it would be helpful to have an option in the contextual menu to run all the tests on that package. Additionally, when selecting several test packages it would be useful to have that option too to just run the tests on those packages. In my case this would be really useful because it will prevent me to run all the GUI tests (they take about 15 minutes) when I am focusing  just on the business logic. Since I know which packages might be affected by my chantes I could just selected them and run the tests there to fix any possible bugs I might have introduced. After that I would run the whole set of tests to be certain everything else works as expected.
Comment 1 Theofanis Oikonomou 2013-01-10 13:03:18 UTC
*** Bug 223129 has been marked as a duplicate of this bug. ***
Comment 2 Theofanis Oikonomou 2013-09-04 14:56:12 UTC

*** This bug has been marked as a duplicate of bug 124313 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo