Bug 20307 - TOMCAT: NPE is thrown when one selects Tomcat 4.0->Internal node
TOMCAT: NPE is thrown when one selects Tomcat 4.0->Internal node
Status: VERIFIED FIXED
Product: serverplugins
Classification: Unclassified
Component: Tomcat
-FFJ-
All All
: P1 (vote)
: -FFJ-
Assigned To: Damian Frach
issues@serverplugins
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-08 06:31 UTC by Mikhail Romanov
Modified: 2002-04-23 10:59 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mikhail Romanov 2002-02-08 06:31:30 UTC
Bug exists in FFJ CE Build 020207.

Properties of Tomcat 4.0->Internal node are not available and
NPE is thrown when one tries to view them.

How to reproduce:

1. Switch to Runtime tab in Explorer
2. Expand Server Registry->Installed Servers->Tocat 4.0->Internal
3. Call properties window
4. Select Internal node and notice, that its properties are not available 
and the following NPE is thrown:

Thu Feb 07 22:30:13 PST 2002: java.lang.NullPointerException: <no message>
java.lang.NullPointerException
        at
org.netbeans.beaninfo.editors.NbProcessDescriptorCustomEditor.<init>(NbProcessDescriptorCustomEditor.java:42)
        at
org.netbeans.beaninfo.editors.NbProcessDescriptorEditor.getCustomEditor(NbProcessDescriptorEditor.java:127)
        at
org.netbeans.modules.tomcat.tomcat40.Tomcat40DataNode$3.getPropertyEditor(Tomcat40DataNode.java:202)
        at
org.openide.explorer.propertysheet.PropertyPanel.updateEditor(PropertyPanel.java:574)
        at
org.openide.explorer.propertysheet.PropertyPanel.<init>(PropertyPanel.java:258)
        at
org.openide.explorer.propertysheet.PropertyPanel.<init>(PropertyPanel.java:264)
        at
org.openide.explorer.propertysheet.PropertySheetTab.fillProperties(PropertySheetTab.java:359)
        at
org.openide.explorer.propertysheet.PropertySheetTab.createPane(PropertySheetTab.java:310)
        at
org.openide.explorer.propertysheet.PropertySheetTab.<init>(PropertySheetTab.java:175)
        at
org.openide.explorer.propertysheet.PropertySheet.refreshPropertySheet(PropertySheet.java:448)
        at
org.openide.explorer.propertysheet.PropertySheet.access$1100(PropertySheet.java:52)
[catch] at
org.openide.explorer.propertysheet.PropertySheet$3.run(PropertySheet.java:593)
        at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:178)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:443)
        at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:190)
        at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:144)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:130)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:98)
Comment 1 Milan Kuchtiak 2002-02-08 14:43:07 UTC
The bug is caused by Damian's changes yesterday.
Comment 2 Damian Frach 2002-02-08 15:03:40 UTC
fixed
Comment 3 Mikhail Romanov 2002-03-15 22:37:17 UTC
Verified in Build 020315.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo