Bug 203053 - Improve USAGES log submitting
Improve USAGES log submitting
Status: RESOLVED FIXED
Product: ide
Classification: Unclassified
Component: Logger
7.1
All All
: P2 (vote)
: 7.2
Assigned To: Martin Entlicher
logger-issues@ide
: PLAN
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-04 13:32 UTC by Tomas Mysik
Modified: 2012-03-07 18:09 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Mysik 2011-10-04 13:32:55 UTC
Currently, the USAGES logs are submitted after 400 events. The problem is that the statistics can be incorrect, especially after new NB version is released (collecting 400 events takes much shorter time for Java development than for PHP development, for example).

The improvement could be: submit USAGES logs after 400 events or 1/2/3/4/? weeks/months/?, whichever comes first.

Thanks.
Comment 1 Martin Entlicher 2012-03-06 10:00:06 UTC
Improved by changeset:   214348:6bce66b50582
http://hg.netbeans.org/main/rev/6bce66b50582

USAGES logs are submitted after 400 events or after 40 days ± one week.
Comment 2 Quality Engineering 2012-03-07 18:09:51 UTC
Integrated into 'main-golden', will be available in build *201203071105* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/6bce66b50582
User: mentlicher@netbeans.org
Log: #203053: USAGES logs are submitted after 400 events or after 40 days (


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo