Bug 202987 - Deadlock between MavenFileOwnerQueryImpl and DefaultProjectBuildingHelper
Deadlock between MavenFileOwnerQueryImpl and DefaultProjectBuildingHelper
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Maven
7.1
PC Linux
: P3 (vote)
: 7.2
Assigned To: Milos Kleint
issues@projects
: THREAD
: 235383 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-03 14:50 UTC by Jesse Glick
Modified: 2013-09-02 08:16 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump (30.19 KB, text/plain)
2011-10-03 14:50 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2011-10-03 14:50:27 UTC
Created attachment 111426 [details]
Thread dump

20110929-99f6dbaa0c84. Created NB Platform App project and IDE hung during opening.
Comment 1 Milos Kleint 2012-02-15 12:06:56 UTC
hmmm, the problem is that NbArtifactFixer will only only attempt to resolve project dependencies but also extensions and projects with extensions.
Comment 2 Milos Kleint 2012-02-15 15:30:17 UTC
http://hg.netbeans.org/core-main/rev/3786a0540b23

created a component inheriting from the DefaultPluginDependenciesResolver that mutes the WorkspaceReader and associated ArtifactFixer instances for the duration of plugin dependencies resolution.

That should resolve the problem with the deadlock, unfortunately I didn't find a way to reproduce the deadlock to verify the hypothesis.
Comment 3 Milos Kleint 2013-09-02 08:16:40 UTC
*** Bug 235383 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo