Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 202907 - [71cat] java.util.regex.PatternSyntaxException: Illegal/unsupported escape sequence near index 4 lib\install\applications\__admingui\WEB-INF\lib\console-core-3.1.1(?:-[0-9bSNAPHOT]+(?:\.[0-9]+(?:_[0-9]+|)|).*
[71cat] java.util.regex.PatternSyntaxException: Illegal/unsupported escape se...
Status: RESOLVED FIXED
Product: serverplugins
Classification: Unclassified
Component: GlassFish
7.0
All All
: P3 (vote)
: TBD
Assigned To: Vince Kraemer
issues@serverplugins
EXCEPTIONS_REPORT
:
: 202863 202905 202908 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-30 22:00 UTC by muellermi
Modified: 2011-10-01 14:05 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (14.56 KB, text/plain)
2011-09-30 22:00 UTC, muellermi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description muellermi 2011-09-30 22:00:27 UTC
Build: NetBeans IDE Dev (Build 201109300601)
VM: Java HotSpot(TM) 64-Bit Server VM, 21.0-b17, Java(TM) SE Runtime Environment, 1.7.0-b147
OS: Windows 7

Stacktrace: 
java.util.regex.PatternSyntaxException: Illegal/unsupported escape sequence near index 4
lib\install\applications\__admingui\WEB-INF\lib\console-core-3.1.1(?:-[0-9bSNAPHOT]+(?:\.[0-9]+(?:_[0-9]+|)|).*|).jar
    ^
   at java.util.regex.Pattern.error(Pattern.java:1924)
   at java.util.regex.Pattern.escape(Pattern.java:2416)
   at java.util.regex.Pattern.atom(Pattern.java:2164)
   at java.util.regex.Pattern.sequence(Pattern.java:2097)
   at java.util.regex.Pattern.expr(Pattern.java:1964)
   at java.util.regex.Pattern.compile(Pattern.java:1665)
Comment 1 muellermi 2011-09-30 22:00:31 UTC
Created attachment 111381 [details]
stacktrace
Comment 2 Vince Kraemer 2011-09-30 23:36:31 UTC
http://hg.netbeans.org/web-main/rev/8fd8c7c62d40

This also appears to have resolved issue 202857.
Comment 3 Vince Kraemer 2011-10-01 00:10:38 UTC
*** Bug 202863 has been marked as a duplicate of this bug. ***
Comment 4 Vince Kraemer 2011-10-01 06:00:26 UTC
*** Bug 202905 has been marked as a duplicate of this bug. ***
Comment 5 Vince Kraemer 2011-10-01 06:04:22 UTC
*** Bug 202908 has been marked as a duplicate of this bug. ***
Comment 6 Quality Engineering 2011-10-01 14:05:27 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/8fd8c7c62d40
User: vince kraemer <vkraemer@netbeans.org>
Log: #202907 : PatternSyntaxException in version ID code


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo