Bug 202902 - getFileSeparatorChar() always returns '/'
getFileSeparatorChar() always returns '/'
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Remote
7.0.1
PC All
: P2 (vote)
: 7.0.1
Assigned To: Andrew Krasny
issues@cnd
701patch2-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-30 16:51 UTC by Andrew Krasny
Modified: 2011-10-11 18:39 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Krasny 2011-09-30 16:51:08 UTC
Return statement is missed in several places in org/netbeans/modules/remote/spi/FileSystemProvider.java...
Comment 1 Andrew Krasny 2011-09-30 17:03:26 UTC
pushed to releases/release701_fixes: http://hg.netbeans.org/releases/rev/cad38042709c
Comment 2 Andrew Krasny 2011-09-30 19:30:29 UTC
pushed to cnd-main as well: http://hg.netbeans.org/cnd-main/rev/dad64a3606d7
Comment 3 Quality Engineering 2011-10-01 14:06:00 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/dad64a3606d7
User: Andrew Krasny <akrasny@netbeans.org>
Log: Bug #202902 - getFileSeparatorChar() always return '/'
(transplanted from cad38042709c09e27a8d41c5ac180473c8883f84)
Comment 4 Vladimir Voskresensky 2011-10-03 09:59:40 UTC
I've reviewed the fix we've made with Andrew and it is definitely correct. But it's hard to consider as safe, because not clear how previously something worked from windows at all
Comment 5 Alexander Pepin 2011-10-05 13:56:37 UTC
Can not reproduce the original bug in build 31 on Windows using DD.
Comment 6 Alexander Pepin 2011-10-05 15:01:53 UTC
No regressions were found so far in DD in OSS dev build #3375
Comment 7 Quality Engineering 2011-10-07 17:35:41 UTC
Integrated into 'releases'
Changeset: http://hg.netbeans.org/releases/rev/cad38042709c
User: Andrew Krasny <akrasny@netbeans.org>
Log: Bug #202902 - getFileSeparatorChar() always return '/'
Comment 8 Alexander Pepin 2011-10-11 12:44:09 UTC
can not reproduce in OSS dev build #3394 (built on NB 7.0.1 patch 2 20111007)
Comment 9 soldatov 2011-10-11 12:59:18 UTC
Can't create project in Samba Remote mode (WindowsXP->Solaris)

org.openide.filesystems.FileStateInvalidException
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.RootObjWindows.createFolder(RootObjWindows.java:194)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.RootObj.createFolder(RootObj.java:258)
	at org.openide.filesystems.FileUtil.createFolder(FileUtil.java:864)
	at org.netbeans.modules.cnd.makeproject.ui.wizards.MakeSampleProjectGenerator.createProjectFromTemplate(MakeSampleProjectGenerator.java:347)
	at org.netbeans.modules.cnd.makeproject.ui.wizards.MakeSampleProjectGenerator.createProjectFromTemplate(MakeSampleProjectGenerator.java:139)
	at org.netbeans.modules.cnd.makeproject.api.ProjectGenerator.createProjectFromTemplate(ProjectGenerator.java:388)
	at org.netbeans.modules.cnd.makeproject.ui.wizards.MakeSampleProjectIterator.instantiate(MakeSampleProjectIterator.java:148)
	at org.netbeans.modules.cnd.makeproject.ui.wizards.MakeSampleProjectIterator.instantiate(MakeSampleProjectIterator.java:133)
	at org.openide.loaders.TemplateWizard$InstantiatingIteratorBridge.instantiate(TemplateWizard.java:1019)
	at org.openide.loaders.TemplateWizard.handleInstantiate(TemplateWizard.java:591)
	at org.openide.loaders.TemplateWizard.instantiateNewObjects(TemplateWizard.java:412)
	at org.openide.loaders.TemplateWizardIterImpl.instantiate(TemplateWizardIterImpl.java:256)
	at org.openide.loaders.TemplateWizardIteratorWrapper.instantiate(TemplateWizardIteratorWrapper.java:168)
	at org.openide.WizardDescriptor.callInstantiateOpen(WizardDescriptor.java:1548)
	at org.openide.WizardDescriptor.callInstantiate(WizardDescriptor.java:1505)
	at org.openide.WizardDescriptor.access$1700(WizardDescriptor.java:137)
[catch] at org.openide.WizardDescriptor$Listener$2$1.run(WizardDescriptor.java:2099)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1424)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1968)
Comment 10 soldatov 2011-10-11 13:18:00 UTC
I filed new issue, because this regression can be or can't be IZ202902 related
Comment 11 Vladimir Voskresensky 2011-10-11 18:39:51 UTC
(In reply to comment #10)
> I filed new issue, because this regression can be or can't be IZ202902 related
thanks, it is not related to this issue, it has some connections with issue#200656


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo