Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 202857 - [71cat] IDE doesn't start GlassFish
[71cat] IDE doesn't start GlassFish
Status: RESOLVED FIXED
Product: serverplugins
Classification: Unclassified
Component: GlassFish
7.1
PC Windows XP
: P1 (vote)
: TBD
Assigned To: Vince Kraemer
issues@serverplugins
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-30 06:56 UTC by muellermi
Modified: 2011-11-16 16:42 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
messages.log (44.89 KB, application/octet-stream)
2011-09-30 07:00 UTC, muellermi
Details
dump (65.08 KB, text/plain)
2011-09-30 07:00 UTC, muellermi
Details
message log as text (44.89 KB, text/plain)
2011-09-30 19:49 UTC, Vince Kraemer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description muellermi 2011-09-30 06:56:04 UTC
Product Version = NetBeans IDE Dev (Build 201109290601)
Operating System = Windows XP version 5.1 running on x86
Java; VM; Vendor = 1.7.0
Runtime = Java HotSpot(TM) Client VM 21.0-b17

From within IDE, GlassFish cann not be started. Unlike a prior build ther is no message like "run --upgrade".
Simple nothing happens, when you try to start glassfish.

When you launch GlassFish from console and press refrech on NB's GlassFish node, it is recognized as running.
Comment 1 muellermi 2011-09-30 07:00:01 UTC
Dump includes these actions
- NB start
- Try to start GF
- refresh GF after manual start on console
Comment 2 muellermi 2011-09-30 07:00:09 UTC
Created attachment 111338 [details]
messages.log
Comment 3 muellermi 2011-09-30 07:00:19 UTC
Created attachment 111339 [details]
dump
Comment 4 muellermi 2011-09-30 07:03:31 UTC
BTW: after starting GF from console, it can be stopped from within NB, but not started again
Comment 5 muellermi 2011-09-30 07:15:24 UTC
Next problem:
After manual starting GF, I can run my app from within NB.
But: If I want to debug my app, NB stops GF (even though I started using debug mode) and tries to restart. Since starting is broken, it wont start again. I'll have to figure out a trick or switch back to previous buils 201109060601 :(
Comment 6 Jiri Skrivanek 2011-09-30 08:05:21 UTC
I can reproduce. Might be connected to bug 202863.
Comment 7 Vince Kraemer 2011-09-30 19:49:15 UTC
Created attachment 111378 [details]
message log as text
Comment 8 Vince Kraemer 2011-10-01 00:12:27 UTC
the fix for issue 202907 (issue 202863) appears to correct this... http://hg.netbeans.org/web-main/rev/8fd8c7c62d40


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo