Bug 202848 - Only one license displayed
Only one license displayed
Status: RESOLVED WORKSFORME
Product: platform
Classification: Unclassified
Component: Autoupdate
7.1
PC Linux
: P3 (vote)
: 7.1
Assigned To: Jiri Rechtacek
au-issues
: UI
Depends on: 200765
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-29 21:23 UTC by Jesse Glick
Modified: 2011-10-26 07:47 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2011-09-29 21:23:14 UTC
When downloading a bunch of plugins with various licenses, the AU wizard only seems to display one of them and ask you to accept it. They should all be displayed somehow - one license per wizard step, perhaps, or a dropdown combo, or simply all appended with some sort of <HR>-like separator in the license text area.
Comment 1 Jiri Rechtacek 2011-10-17 14:27:38 UTC
It works already by described suggestion, a license for each plugin (including invisible modules if any) is contained in License Agreement area, each of them preceded by line-separator and name of plugin. If the case more plugins has the same license (i.e. whole text), names of plugins with the same licenses are separated by comma sign.
Comment 2 Jesse Glick 2011-10-17 21:55:36 UTC
Does seem to be showing them all. It is a terrible UI, but by design I guess.
Comment 3 dlipin 2011-10-18 12:37:40 UTC
See also Issue #172599.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo