Bug 202771 - Cannot debug missing index file (xdebug)
Cannot debug missing index file (xdebug)
Status: VERIFIED FIXED
Product: php
Classification: Unclassified
Component: Project
7.1
All All
: P1 with 3 votes (vote)
: 7.1
Assigned To: Tomas Mysik
issues@php
: 71_HR_FIX
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-28 10:56 UTC by ranyardm
Modified: 2011-12-02 00:30 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ranyardm 2011-09-28 10:56:55 UTC
Netbeans nightly 201109260601 fails to debug any php web project - debug single file runs fine (php and debugs) but debug project will not accept that the index file exists, no matter the configuration with the error message Cannot debug missing index file.

I tested this with a "new php project" as well as an existing project.

Works fine in 7.0.1
Comment 1 Ondrej Brejla 2011-09-29 07:46:51 UTC
Can you upload simple PHP project with all settings, where the problem occurs? Thanks a lot.
Comment 2 Ondrej Brejla 2011-10-12 09:34:35 UTC
I get "Cannot debug missing Index file" error when I really don't have any index.php file in my project and if "index.php" file is set in "Project Properties -> Run Configuration -> Index File".

If I select another file (which really exists) in this config, everything works fine and I can debug whole project. I think that it's expected behaviour.

How you would like to debug project as a "Local Web Site (...)" if you don't have an entry point?

Maybe I don't understand you what you mean or what you expect...can you attach your project, where the problem occurs and describe everything again and more clearly? Otherwise this is invalid issue.
Comment 3 lazyguru 2011-10-26 20:54:23 UTC
I get the same issue.  The exact same project will debug in 7.0.1, but not in 7.1.  The project has the webroot as a subdirectory with an index.php in the webroot directory.

So directory structure looks like:


Project Name
  -> Source Files
      ->  webroot
         -> index.php

I have the webroot selected in the project settings and I select the index.php.  When I try to run the debugger, I get "Cannot debug missing index file: index.php".  If I try to select a different file, I still get the message.

I was able to work around the issue by creating a dummy index.php in the root of my project.

Project Name
  -> Source Files
      -> index.php   <-- This is the dummy index.php
      ->  webroot
         -> index.php  <-- This is the real index.php

However, it appears that the project root is being used for debugging instead of the defined webroot.  All of my breakpoints are ignored.  If I set Netbeans to break at the first line of code, it uses my dummy index.php.  If I step-over, etc... it still just stays in my dummy index.php.
Comment 4 maxym 2011-11-21 20:38:08 UTC
I can confirm.
7.1 beta cannot run project debug due to missing index.php file, which of course exists. 7.0.1 works as expected with the same project.


Recently I downloaded last updates for 7.1beta and problem still persist. I hope to be fixed soon because I found git support a lot better than in 7.0.1, on other hand I cannot live without debuging

Additionaly 7.1 beta ask for selecting debug sources (SS php, SS php with JS, with supress checkbox and note: you can change these settings in Project properties. Maybe i'm blind, but I cannot see such settings in Project properties.

best regards
Comment 5 mago_ebon 2011-11-22 03:39:52 UTC
The problem happened to me when I created a new PHP project from existing sources, and selected the option "Put NetBeans metadata into a separate directory". When I didn't select that option everything worked fine. I confirmed the behavior.
Comment 6 kolen 2011-11-22 06:09:07 UTC
> and selected the option "Put NetBeans metadata into a separate
directory"

Yes, occured for me also when putting metadata in separate directory. Didn't tried when putting metadata in project dir.
Comment 7 maxym 2011-11-22 09:23:18 UTC
I didn't think project meta files location makes difference. But yes, I have also those files located in other location than project files

best regards
Comment 8 Ondrej Brejla 2011-11-22 09:24:26 UTC
Now I can reproduce it, but it seems to be PHP Project's issue, so reassigning to Tomas. Thanks for your reports, it really helped me to reproduce it!
Comment 9 Ondrej Brejla 2011-11-22 09:29:13 UTC
Ccing Vlada and increasing priority...it's 7.1 backport candidate.
Comment 10 Tomas Mysik 2011-11-22 11:20:57 UTC
Fixed, Láďo please verify so I can backport it to the NB 7.1 branch.

http://hg.netbeans.org/web-main/rev/d14381e09129

Thanks.
Comment 11 Vladimir Riha 2011-11-22 19:06:13 UTC
Verified. I tried project structure as described in comment #3 with and without putting metadata to separate folder.

Product Version: NetBeans IDE Dev (Build 2011-11-22_12-25-36 )
Java: 1.6.0_29; Java HotSpot(TM) 64-Bit Server VM 20.4-b02
System: Linux version 2.6.38-12-generic running on amd64; UTF-8; en_US (nb)
Comment 12 Tomas Mysik 2011-11-23 09:33:42 UTC
Transplanted to the 7.1 branch, please verify. Thanks.

http://hg.netbeans.org/releases/rev/e153642a198a
Comment 13 Quality Engineering 2011-11-23 15:59:44 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/d14381e09129
User: Tomas Mysik <tmysik@netbeans.org>
Log: #202771 - Cannot debug missing index file (xdebug)
Comment 14 Quality Engineering 2011-11-24 07:16:12 UTC
Integrated into 'releases'
Changeset: http://hg.netbeans.org/releases/rev/e153642a198a
User: Tomas Mysik <tmysik@netbeans.org>
Log: #202771 - Cannot debug missing index file (xdebug)
(transplanted from d14381e091296db394559661199ad768ead49f1e)
Comment 15 Vladimir Riha 2011-11-24 11:02:33 UTC
Verified in RC1

Product Version: NetBeans IDE 7.1 RC1 (Build 201111232200)
Java: 1.7.0_02; Java HotSpot(TM) Client VM 22.0-b10
System: Linux version 3.0.0-12-generic-pae running on i386; UTF-8; en_US (nb)
Comment 16 maxym 2011-12-02 00:30:33 UTC
I can confirm. Works like a charm now.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo