Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 202750 - x86 x 64 versions conflict for JavaFX
x86 x 64 versions conflict for JavaFX
Status: RESOLVED DUPLICATE of bug 202165
Product: javafx
Classification: Unclassified
Component: Platform
7.1
PC Windows 7 x64
: P3 (vote)
: TBD
Assigned To: Anton Chechel
issues@javafx
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-27 17:06 UTC by askirov
Modified: 2011-09-29 17:01 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description askirov 2011-09-27 17:06:06 UTC
We test JavaFX2.0

I had everything for x86 (32-bit) (in Program Files (x86))

I have installed java7_64 and JavaFX2.0_64. (in Program Files)

Tried to compile some project which was compiling before and got:

Error: failed to msvcr100.dll java.lang.UnsatisfiedLinkError: C:\Program Files\Oracle\JavaFX 2.0 SDK\rt\bin\msvcr100.dll: Can't find dependent libraries
Exception in thread "main" java.lang.RuntimeException: java.lang.UnsatisfiedLinkError: C:\Program Files\Oracle\JavaFX 2.0 SDK\rt\bin\mat.dll: Can't find dependent libraries
	at com.sun.javafx.tk.quantum.QuantumToolkit.startup(QuantumToolkit.java:291)
	at com.sun.javafx.application.PlatformImpl.startup(PlatformImpl.java:68)
	at javafx.embed.swing.JFXPanel.initFx(JFXPanel.java:127)
	at javafx.embed.swing.JFXPanel.<init>(JFXPanel.java:144)
	at swingbrowser2.Main.main(Main.java:19)
Caused by: java.lang.UnsatisfiedLinkError: C:\Program Files\Oracle\JavaFX 2.0 SDK\rt\bin\mat.dll: Can't find dependent libraries
	at java.lang.ClassLoader$NativeLibrary.load(Native Method)
	at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1807)
	at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1703)
	at java.lang.Runtime.load0(Runtime.java:770)
	at java.lang.System.load(System.java:1003)
	at com.sun.glass.utils.NativeLibLoader.loadLibraryFullPath(NativeLibLoader.java:155)
	at com.sun.glass.utils.NativeLibLoader.loadLibraryInternal(NativeLibLoader.java:85)
	at com.sun.glass.utils.NativeLibLoader.loadLibrary(NativeLibLoader.java:30)
	at com.sun.glass.ui.Application$1.run(Application.java:28)
	at java.security.AccessController.doPrivileged(Native Method)
	at com.sun.glass.ui.Application.loadNativeLibrary(Application.java:26)
	at com.sun.glass.ui.win.WinApplication.<clinit>(WinApplication.java:33)
	at com.sun.glass.ui.win.WinPlatformFactory.createApplication(WinPlatformFactory.java:20)
	at com.sun.glass.ui.win.WinPlatformFactory.createApplication(WinPlatformFactory.java:17)
	at com.sun.glass.ui.Application.Run(Application.java:51)
	at com.sun.javafx.tk.quantum.QuantumToolkit.startup(QuantumToolkit.java:281)
	... 4 more
Java Result: 1

After that I made a trick: In project properties, Managing platforms I manually created a new platform, which is of Java7x64. And got a compiling project again. After setting "Default_JFX_platform" I've got the error again. We believe, that is an issue about x86 x64 conflict. Some platform is chosed by default, not according to explicitly set options.
Comment 1 Stepan Zebra 2011-09-29 17:01:28 UTC

*** This bug has been marked as a duplicate of bug 202165 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo