Bug 202684 - Editor no longer acquires keyboard focus
Editor no longer acquires keyboard focus
Status: RESOLVED DUPLICATE of bug 201823
Product: editor
Classification: Unclassified
Component: -- Other --
7.1
PC Windows 7
: P3 (vote)
: TBD
Assigned To: Milutin Kristofic
issues@editor
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-26 16:04 UTC by _ gtzabari
Modified: 2011-09-27 08:27 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ gtzabari 2011-09-26 16:04:48 UTC
Product Version: NetBeans IDE Dev (Build 201109250601)
Java: 1.7.0; Java HotSpot(TM) Client VM 21.0-b17
System: Windows 7 version 6.1 running on x86; Cp1252; en_US (nb)
User directory: C:\Users\g.tzabari\.netbeans\dev
Cache directory: C:\Users\g.tzabari\.netbeans\dev\var\cache

1. Using the keyboard, select a Java file in Projects tab (that is not already open in the editor).
2. Hit ENTER
3. Notice that the keyboard focus remains in the Projects tab. In previous versions, focus used to move to the newly-opened file.

It's not clear whether the new behavior is by-design or a regression. I believe the behavior changed sometime during the past 2 weeks.
Comment 1 Milutin Kristofic 2011-09-27 08:27:31 UTC
It was reintroduce in previous dev builds, but it should be fixed. 

It works for me
Product Version: NetBeans IDE Dev (Build 20110927-563bb4857265)
Java: 1.6.0_26; Java HotSpot(TM) 64-Bit Server VM 20.1-b02

*** This bug has been marked as a duplicate of bug 201823 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo