Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 202658 - [71cat] allow to rename JSF var
[71cat] allow to rename JSF var
Status: RESOLVED FIXED
Product: javaee
Classification: Unclassified
Component: JSF Editor
7.1
PC Windows XP
: P3 (vote)
: 7.2
Assigned To: Marek Fukala
issues@javaee
:
: 202702 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-26 09:46 UTC by muellermi
Modified: 2012-04-24 07:20 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description muellermi 2011-09-26 09:46:09 UTC
Product Version = NetBeans IDE 7.1 Beta (Build 201109222201)
Operating System = Windows XP version 5.1 running on x86
Java; VM; Vendor = 1.7.0
Runtime = Java HotSpot(TM) Client VM 21.0-b17

Assume a JSF page with this code
        <h:dataTable [...snip code ...] var="p">
Now, the developper wants to rename the var. He highlights "p" and presses Ctrl-R
some characters two lines above will be highlighted as if for rename.
Same happens, if you place the pointer above "var" or something else.
Only, if you place the pointer over a method or property e.g. "p.myProperty", NB alters "The rename factory cannot..."
a) if rename is not supported in JSF, alter it everywhere
b) [prefereable] support renaming
Comment 1 muellermi 2011-09-26 09:47:07 UTC
a) if rename is not supported in JSF, alter it everywhere
typo, not "alter", should be "alert"
Comment 2 Marek Fukala 2011-09-26 12:00:55 UTC
I must admit I'm bit confused by the report. 

Are you complaining about the instant rename of local variables in JSF page? Such feature is not implemented yet.

Currently we only support the "full" rename refactoring of beans/methods in expression language and java classes (works only from java class side).
Comment 3 Martin Fousek 2011-09-27 08:37:40 UTC
It looks to me as follows... Author had some paired tag so the rename action was invoked on the tag instead on the highlighted variable. 

to muellermi: 
It's context dependent where the rename action is enabled and where not and the IDE is offering that action anywhere where possible - option a) would just descrease IDE features.

About option b). Actually there are two currently not supported functionalities, as mentioned Marek. Local JSF page variables at all and also refactoring for any variables within .xhtml page. 

I would mark this as an enhancement for Next release, your opinion - Marek, muellermi?
Comment 4 Marek Fukala 2011-09-27 12:02:07 UTC
*** Bug 202702 has been marked as a duplicate of this bug. ***
Comment 5 Marek Fukala 2012-04-24 07:20:28 UTC
a) if rename is not supported in JSF, alert it everywhere
That's how it behaves now in current dev builds.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo