Bug 202639 - NullPointerException at org.netbeans.modules.cnd.navigation.macroview.MacroExpansionViewUtils.createExpandedContextDocument
NullPointerException at org.netbeans.modules.cnd.navigation.macroview.MacroEx...
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Editor
7.1
All All
: P2 (vote)
: 7.1
Assigned To: Vladimir Voskresensky
issues@cnd
EXCEPTIONS_REPORT, 701patch2-verified
:
: 205265 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-26 03:56 UTC by Vladimir Kvashin
Modified: 2012-04-17 14:28 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.00 KB, text/plain)
2011-09-26 03:56 UTC, Vladimir Kvashin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Kvashin 2011-09-26 03:56:49 UTC
Build: Oracle Solaris Studio Dev 2011/09/13 cd796d70881a
VM: Java HotSpot(TM) Server VM, 11.0-b15, Java(TM) SE Runtime Environment, 1.6.0_10-b33
OS: Windows XP

User Comments:
vkvashin: In full remote mysql project, in editor, selected navigate > show macro expansion




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.cnd.navigation.macroview.MacroExpansionViewUtils.createExpandedContextDocument(MacroExpansionViewUtils.java:201)
   at org.netbeans.modules.cnd.navigation.macroview.impl.services.MacroExpansionViewProviderImpl.showMacroExpansionView(MacroExpansionViewProviderImpl.java:111)
   at org.netbeans.modules.cnd.api.model.services.CsmMacroExpansion.showMacroExpansionView(CsmMacroExpansion.java:253)
   at org.netbeans.modules.cnd.navigation.macroview.ShowMacroExpansionAction.performAction(ShowMacroExpansionAction.java:70)
   at org.openide.util.actions.NodeAction$DelegateAction$1.run(NodeAction.java:586)
   at org.openide.util.actions.ActionInvoker$1.run(ActionInvoker.java:95)
Comment 1 Vladimir Kvashin 2011-09-26 03:56:55 UTC
Created attachment 111165 [details]
stacktrace
Comment 2 Vladimir Voskresensky 2011-09-26 16:10:07 UTC
fixed:
http://hg.netbeans.org/cnd-main/rev/e3e9baedc303
Comment 3 soldatov 2011-09-27 13:00:32 UTC
verified in cnd-build-5958-on-20110927 build
Comment 4 nnnnnk 2011-09-27 15:19:52 UTC
Reviewed. Fix is safe and correct.
Comment 5 Vladimir Voskresensky 2011-09-27 15:25:16 UTC
integrated into releases/release701_fixes 
http://hg.netbeans.org/releases/rev/9a95c1bf70ae
Comment 6 soldatov 2011-09-30 07:33:40 UTC
verified in NetBeans IDE 7.0.1 (Build 201109292036)
Comment 7 Vladimir Voskresensky 2012-04-17 14:28:44 UTC
*** Bug 205265 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo