Bug 202568 - WindowsHostInfoProvider uses NativeProcessBuilder in initialization, which may cause deadlock
WindowsHostInfoProvider uses NativeProcessBuilder in initialization, which ma...
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: execution
7.1
PC All
: P2 (vote)
: 7.1
Assigned To: Andrew Krasny
issues@cnd
701patch2-verified
:
: 204209 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-23 14:46 UTC by Andrew Krasny
Modified: 2011-10-25 13:44 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
org-netbeans-modules-cnd-makeproject.jar with reverted fix for 202550 (3.47 MB, application/octet-stream)
2011-09-28 11:28 UTC, Andrew Krasny
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Krasny 2011-09-23 14:46:16 UTC
This is a follow-up bug after Bug 202550 - IDE hangs on start with existing project (http://netbeans.org/bugzilla/show_bug.cgi?id=202550)
The real problem is that getting HostInfo on a Windows host may cause a lock if called before info is available.
Comment 1 Andrew Krasny 2011-09-27 14:54:38 UTC
fixed in trunk: http://hg.netbeans.org/cnd-main/rev/2e950e09bed1
Comment 2 Vladimir Voskresensky 2011-09-27 16:13:03 UTC
it might affect windows distribution
Comment 3 Vladimir Voskresensky 2011-09-28 11:09:00 UTC
I have reviewed the fix. It is safe and correct
Comment 4 Andrew Krasny 2011-09-28 11:27:14 UTC
Here is a plan we want to propose for QA to test this:

Original issue (202550) was that IDE hangs on start if there were open projects... 
That issue was fixed in cnd.makeproject module and it 'masked' the root cause of the problem. So after that fix everything works, but *this* issue exists. 

Suggestion is to 'revert' the fix of 202550 by substituting makeproject.jar file and see that 202550 is reproducible.
Then get nativeexecution.jar with *this* fix and make sure that 202550 is not reproducible (even without a fix in makeproject.jar).

Fixed nativeexecution.jar is in trunk;
makeproject.jar with 'reverted' fix of 202550 is attached.
Comment 5 Andrew Krasny 2011-09-28 11:28:51 UTC
Created attachment 111270 [details]
org-netbeans-modules-cnd-makeproject.jar with reverted fix for 202550
Comment 6 Quality Engineering 2011-09-28 14:03:08 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/2e950e09bed1
User: Andrew Krasny <akrasny@netbeans.org>
Log: Bug #202568 - WindowsHostInfoProvider uses NativeProcessBuilder in initialization, which may cause deadlock
Comment 7 Alexander Pepin 2011-09-29 12:46:40 UTC
verified in trunk build 20110929.
please push the fix into 7.0.1 patch2.
Comment 8 Andrew Krasny 2011-09-29 13:51:55 UTC
Transplanted to releases/701_fixes: http://hg.netbeans.org/releases/rev/8b15ad6a7355
Comment 9 Quality Engineering 2011-09-29 22:46:10 UTC
Integrated into 'releases'
Changeset: http://hg.netbeans.org/releases/rev/8b15ad6a7355
User: Andrew Krasny <akrasny@netbeans.org>
Log: Bug #202568 - WindowsHostInfoProvider uses NativeProcessBuilder in initialization, which may cause deadlock
(transplanted from 2e950e09bed1636ed045b82830636c5826fb6dc5)
Comment 10 Alexander Pepin 2011-09-30 11:16:34 UTC
verified in 7.0.1 patch 2 build 20110930
Comment 11 Egor Ushakov 2011-10-25 13:44:55 UTC
*** Bug 204209 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo