Bug 202515 - segfault in libgcrypt11
segfault in libgcrypt11
Status: RESOLVED DUPLICATE of bug 209226
Product: platform
Classification: Unclassified
Component: Options&Settings
7.0.1
PC Linux
: P3 (vote)
: TBD
Assigned To: Jesse Glick
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-22 15:00 UTC by mvy
Modified: 2012-03-07 17:27 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
crash report (44.96 KB, text/plain)
2011-09-22 15:01 UTC, mvy
Details
messages.log (105.24 KB, application/octet-stream)
2011-10-19 09:29 UTC, mvy
Details
SIGSEGV log (53.14 KB, text/x-log)
2012-03-07 14:59 UTC, Vladimir Riha
Details
IDE log (21.97 KB, text/x-log)
2012-03-07 15:00 UTC, Vladimir Riha
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mvy 2011-09-22 15:00:49 UTC
Hello, after I upgraded to Ubuntu Oneiric and libgcrypt11-1.5.0, Netbeans worked for a couple of starts, then it suddenly started to crash both with sun-jdk 1.6.0.26 and openjdk 1.6, on each start.
I am attaching the segfault debug info. After downgrading to older libgcrypt11-1.4.6 library (found in Natty), things seem to work. Is there some kind of workaround until this is fixed? Thank you :)
Comment 1 mvy 2011-09-22 15:01:29 UTC
Created attachment 111052 [details]
crash report
Comment 2 mvy 2011-09-22 15:15:59 UTC
The workaround is to grab the older libgcrypt11-1.4.6 (the libgcrypt.so.11.6.0 file), copy it somewhere, e.g. /home/foo/lib/, make a symlink named libgcrypt.so.11 to it, then edit the bin/netbeans script and add the following line to the start:


export LD_LIBRARY_PATH=/home/foo/lib:$LD_LIBRARY_PATH
Comment 3 Jesse Glick 2011-09-26 12:26:38 UTC
The IDE's Java EE server registry is saving a password to the GNOME Keyring. Looks like there is some sort of incompatibility in Oneiric's implementation of the Keyring API? -J-Dnetbeans.keyring.no.native=true (e.g. in etc/netbeans.conf) would be an alternate workaround (NB would fall back to a Firefox-like master password system in this case).
Comment 4 Jesse Glick 2011-10-18 22:51:33 UTC
What is the version number next to org.netbeans.modules.keyring.impl in your log file (which you did not attach)? I need to know if it is 1.3.1 (original 7.0.1) or 1.3.2 (patch update incl. fix for bug #198921).

Anyone from QE running Oneiric who can check whether this is reproducible? I plan to upgrade soon myself but have not gotten to it yet.
Comment 5 Marian Mirilovic 2011-10-19 07:24:14 UTC
(In reply to comment #4)
> Anyone from QE running Oneiric who can check whether this is reproducible? I
> plan to upgrade soon myself but have not gotten to it yet.

Not yet ... we plan to do so after 7.1
Comment 6 mvy 2011-10-19 09:27:40 UTC
Sorry about missing log - attaching.
This bug is quite strange - I recently upgraded to Oneiric at three more computers, and on those computers Netbeans works correctly. It only crashes on a single computer. I am unable to see what's different between those computers.
Comment 7 mvy 2011-10-19 09:29:03 UTC
Created attachment 112208 [details]
messages.log
Comment 8 mvy 2011-10-19 09:30:04 UTC
org.netbeans.keyring.impl: 1.3.2 201108310202
Comment 9 Jesse Glick 2011-10-30 03:55:06 UTC
Just did a clean install of Oneiric with amd64 and am not getting this problem, though I am seeing bug #203735.
Comment 10 Jesse Glick 2012-02-13 15:12:15 UTC
No other reports that I know of. Might be specific to a particular keyring entry, etc. Check in 7.1.
Comment 11 Vladimir Riha 2012-03-07 14:58:37 UTC
I can reproduce it on Ubuntu 11.10 64b, JDK 7u3 (32b). 

Steps to reproduce:
1) start NB with fresh user dir & cache dir
2) New Project | PHP | PHP App from remote server
3) Follow with default settings up to step 3 "Remote configuration"
4) There press "Manage..."
5) fill in FTP data (including username & password) and press OK
=> NetBeans crashes

This scenario works for several times and then it starts crashing

If it's important, I have encrypted home folder (set up during Ubuntu installation). However I have another PC with Ubuntu 11.04 64b with also encrypted home folder and it works without problem.
Comment 12 Vladimir Riha 2012-03-07 14:59:33 UTC
Created attachment 116433 [details]
SIGSEGV log
Comment 13 Vladimir Riha 2012-03-07 15:00:04 UTC
Created attachment 116435 [details]
IDE log
Comment 14 Jesse Glick 2012-03-07 16:36:57 UTC
Sounds the same as bug #209226. No idea yet how to reproduce.

*** This bug has been marked as a duplicate of bug 209226 ***
Comment 15 Jesse Glick 2012-03-07 16:37:57 UTC
Do not move the Version field forward - only, if appropriate, backward.
Comment 16 Vladimir Riha 2012-03-07 17:27:06 UTC
Sorry for the version change. If you want I can provide some more logging (assuming that it will happen again if I start fresh NetBeans without the workaround from comment #3).


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo