Bug 202474 - Code in editor not redrawned correctly after Collapse All - Expand All
Code in editor not redrawned correctly after Collapse All - Expand All
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Painting & Printing
7.1
PC Linux
: P2 (vote)
: 7.1
Assigned To: Miloslav Metelka
issues@editor
: 71_HR_FIX
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-22 09:05 UTC by Vladimir Riha
Modified: 2011-12-01 16:20 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
screenshot (103.77 KB, image/png)
2011-09-22 09:05 UTC, Vladimir Riha
Details
sample file (406 bytes, application/x-php)
2011-09-22 09:08 UTC, Vladimir Riha
Details
ide log (38.58 KB, text/x-log)
2011-09-27 06:23 UTC, Vladimir Riha
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Riha 2011-09-22 09:05:37 UTC
Created attachment 111013 [details]
screenshot

Reproducible

Open the sample file (I reproduced it in new html file as well), place cursor somewhere inside the document (not the last line, this seems to work) and press Ctrl+Shift+- to collapse all folds. Then press Ctrl+Shift++ to expand them (clicking on the top marking fold causes the same). The result is that some of the code is not displayed. It displayes immediately after for example left mouse click in the editor window. Although it's easy to make the code visible again, I think this should be P2 at least.



Product Version: NetBeans IDE 7.1 Beta (Build 201109212202)
Java: 1.7.0; Java HotSpot(TM) Client VM 21.0-b17
System: Linux version 2.6.38-11-generic running on i386; UTF-8; en_US (nb)
Comment 1 Vladimir Riha 2011-09-22 09:08:22 UTC
Created attachment 111014 [details]
sample file

Just note. On Mac, with HTML file some of the tags were displayed after some time (but not all).
Comment 2 Marian Mirilovic 2011-09-22 12:00:38 UTC
Not a stopper for NB 7.1 Beta, but needs to be addressed by 7.1 FCS.
Comment 3 Svata Dedic 2011-09-23 06:33:56 UTC
Again, it's hard to reproduce here - seems also as a timing issue. 

According to the screenshot, the folding toolbar has painted correctly (the sidebar appeared at full height).

Maybe another sync issue in view hierarchy ?
Comment 4 Vladimir Riha 2011-09-23 06:50:11 UTC
Why is it hard to reproduce? I can reproduce it with 100% reliability the way I described
Comment 5 Jiri Prox 2011-09-23 09:08:04 UTC
I can reproduce it as well, just following the description


Product Version: NetBeans IDE 7.1 Beta (Build 201109222201)
Java: 1.7.0; Java HotSpot(TM) Client VM 21.0-b17
System: Windows 7 version 6.1 running on x86; Cp1250; en_US (nb)
User directory: C:\Users\jprox\.netbeans\7.1beta
Cache directory: C:\Users\jprox\.netbeans\7.1beta\var\cache
Comment 6 Miloslav Metelka 2011-09-26 09:41:38 UTC
Unfortunately I'm unable to reproduce.
Jirko, could you please try to reproduce in latest dev build and first please open Tools->Options->Keymap and search for "Dump" and map a shortcut e.g. Ctrl+Shift+F10 to "Dump View Hierarchy" action. Once the problem happens please press the shortcut and the action should dump the view hierarchy info into the console. Please attach the console output (or messages.log) to the issue? Thanks.
Comment 7 Vladimir Riha 2011-09-27 06:23:55 UTC
Created attachment 111216 [details]
ide log

Here's the log with "Dump View Hierarchy" output.


Product Version: NetBeans IDE Dev (Build 201109260601)
Java: 1.7.0; Java HotSpot(TM) Client VM 21.0-b17
System: Linux version 2.6.38-11-generic running on i386; UTF-8; en_US (nb)
Comment 8 Miloslav Metelka 2011-11-29 15:28:33 UTC
Strange, I'm now able to reproduce the problem easily.
There was a missing repaint of newly added paragraph views. Fixed.
I'd like to ask QE for testing and Honza L. for code review. Thanks.

http://hg.netbeans.org/jet-main/rev/9d2292f8fc77
Comment 9 Jan Lahoda 2011-11-29 16:50:23 UTC
Seems fine to me.
Comment 10 Miloslav Metelka 2011-11-29 17:14:48 UTC
Integrated into release71:
9d2292f8fc77 transplanted to da11681fd3eb
Comment 11 Quality Engineering 2011-11-30 07:12:26 UTC
Integrated into 'releases'
Changeset: http://hg.netbeans.org/releases/rev/da11681fd3eb
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #202474 - Code in editor not redrawned correctly after Collapse All - Expand All.
(transplanted from 9d2292f8fc77ab5b1a2a366d4e30f56ef151e0b2)
Comment 12 Quality Engineering 2011-12-01 12:09:55 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/9d2292f8fc77
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #202474 - Code in editor not redrawned correctly after Collapse All - Expand All.
Comment 13 Vladimir Riha 2011-12-01 16:20:59 UTC
verified

Product Version: NetBeans IDE 7.1 RC2 (Build 201111302200)
Java: 1.7.0_02; Java HotSpot(TM) Client VM 22.0-b10
System: Linux version 3.0.0-13-generic-pae running on i386; UTF-8; en_US (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo