Bug 202366 - [71cat] NullPointerException: Null child at index 0, parent: ObjectArrayFieldVariable [ 0], model: org.netbeans.spi.viewmodel.Models$CompoundModel@633db8f2 TreeModel = org.netbeans.spi.viewmodel.Models$Comp
[71cat] NullPointerException: Null child at index 0, parent: ObjectArrayField...
Status: NEW
Product: debugger
Classification: Unclassified
Component: Code
7.0
All All
: P4 (vote)
: 7.2
Assigned To: Martin Entlicher
issues@debugger
EXCEPTIONS_REPORT
: RANDOM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-20 15:41 UTC by stefan79
Modified: 2011-09-21 12:31 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.90 KB, text/plain)
2011-09-20 15:41 UTC, stefan79
Details

Note You need to log in before you can comment on or make changes to this bug.
Description stefan79 2011-09-20 15:41:08 UTC
Build: NetBeans IDE Dev (Build 201109180600)
VM: Java HotSpot(TM) 64-Bit Server VM, 20.0-b11, Java(TM) SE Runtime Environment, 1.6.0_25-b06
OS: Windows 7

User Comments:
GUEST: While debugging J2ME application in WTK 2.5.2 emulator an exception occured on midlet relaunch in midlet suite.
Sorry for my bad English.
Michael

GUEST: Was stopping debuggee

GUEST: I had pressed the button "Finish debugging session"

stefan79: Stopped Debugging.




Stacktrace: 
java.lang.NullPointerException: Null child at index 0, parent: ObjectArrayFieldVariable [ 0], model: org.netbeans.spi.viewmodel.Models$CompoundModel@633db8f2
  TreeModel = org.netbeans.spi.viewmodel.Models$CompoundTreeModel@63c5e316
    org.netbeans.modules.debugger.jpda.models.PendingActionsFilter@5b00de4f
      org.netbeans.modules.debugger.jpda.ui.models.VariablesTreeModelFilter@56dc785a
        org.netbeans.modules.debugger.jpda.ui.models.VariablesTreeModelFilterSI@24618943
          org.netbeans.spi.viewmodel.Models$DelegatingTreeModel@73ca9392
    org.netbeans.modules.debugger.jpda.models.LocalsTreeModel@431fd172
  NodeModel = org.netbeans.spi.viewmodel.Models$CompoundNodeModel@4417ce2
    org.netbeans.modules.debugger.jpda.models.LabelVarsFilter@7f7aa05d
      org.netbeans.modules.debugger.jpda.ui.models.VariablesTreeModelFilter@56dc785a
        org.netbeans.modules.debugger.jpda.ui.models.VariablesTreeModelFilterSI@24618943
        org.netbeans.modules.debugger.jpda.ui.models.VariablesNodeModel@5b6784
   at org.netbeans.modules.viewmodel.TreeModelNode$TreeModelChildren.applyChildren(TreeModelNode.java:1418)
   at org.netbeans.modules.viewmodel.TreeModelNode$TreeModelChildren.refreshLazyChildren(TreeModelNode.java:1395)
   at org.netbeans.modules.viewmodel.TreeModelNode$TreeModelChildren.refreshChildren(TreeModelNode.java:1250)
   at org.netbeans.modules.viewmodel.TreeModelNode$TreeModelChildren.addNotify(TreeModelNode.java:1238)
   at org.openide.nodes.Children.callAddNotify(Children.java:568)
   at org.openide.nodes.EntrySupport$Default.getArray(EntrySupport.java:770)
Comment 1 stefan79 2011-09-20 15:41:11 UTC
Created attachment 110922 [details]
stacktrace
Comment 2 Martin Entlicher 2011-09-21 12:31:50 UTC
This must be very random - I'm not able to reproduce this issue.
From the code it's very hard to find out where the null value comes from.
Changing priority to P4 - since it occurs during finish of debugger session, it does not have any negative impact.
Please provide steps to reproduce if there are some.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo