Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 202328 - NetBeans does not autocreate Java platform or recognize JavaFX SDK
NetBeans does not autocreate Java platform or recognize JavaFX SDK
Status: VERIFIED FIXED
Product: javafx
Classification: Unclassified
Component: Platform
7.1
PC Windows Vista
: P1 (vote)
: 7.1
Assigned To: Anton Chechel
issues@javafx
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-19 17:55 UTC by Jeffrey Rubinoff
Modified: 2011-09-22 14:53 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeffrey Rubinoff 2011-09-19 17:55:36 UTC
Product Version = NetBeans IDE Dev (Build 201109190600)
Operating System = Windows Vista version 6.0 running on x86
Java; VM; Vendor = 1.6.0_27
Runtime = Java HotSpot(TM) Client VM 20.2-b06

I have JavaFX SDK and Runtime installed in the default locations, C:/Program Files/Oracle. When I create a JavaFX Application for the first time, NetBeans does not autocreate a Java platform. Worse, when I create a Java Platform manually and indicate the paths to JavaFX SDK and Runtime, NetBeans insists that the platform is invalid.
When I try this on the 201109140600 build, it works correctly.
Comment 1 Stepan Zebra 2011-09-20 09:26:39 UTC
I can confirm there are some trouble with setting up JFX platform manually. I noticed it yesterday while I was making the list of not working autodetection combinations (Issue 202315). Some combinations that are valid, and was working in previous builds after manual setup, are marked as invalid and can't be used now. The behavior seems to be somehow dependent on the type of JDK that is used to run NetBeans. I'm testing all possible scenarios now and will send results asap.
Comment 2 Anton Chechel 2011-09-20 13:24:11 UTC
I can reproduce it. I confirm there is a bug in yesterday's build (201109190600). Determination of compatibility of architecture (32b vs 64b) of currently running VM with given JavaFX Runtime is not working properly. So user is not able to create new JavaFX enabled platform no matter what. The same situation with platform autocreation.

Increasing priority to P1.
Comment 3 Anton Chechel 2011-09-20 15:24:42 UTC
fixed
http://hg.netbeans.org/jet-main/rev/9a9fe2bec3b2
Comment 4 Jeffrey Rubinoff 2011-09-21 14:04:16 UTC
Problem still there in build 09202329. Has your fix been propagated yet?
Comment 5 Jeffrey Rubinoff 2011-09-21 15:50:04 UTC
Works on first beta build, 09210919
Comment 6 Quality Engineering 2011-09-22 14:53:22 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/9a9fe2bec3b2
User: Anton Chechel <manowar@netbeans.org>
Log: #202328: disabling achitecture compatibility check, doesn't work on some Windows machines


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo