Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 202315 - Platform automatic detection doesn't work for some combinations
Platform automatic detection doesn't work for some combinations
Status: RESOLVED DUPLICATE of bug 202165
Product: javafx
Classification: Unclassified
Component: Platform
7.1
PC Other
: P2 (vote)
: 7.1
Assigned To: Anton Chechel
issues@javafx
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-19 15:15 UTC by Anton Chechel
Modified: 2011-09-23 11:34 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anton Chechel 2011-09-19 15:15:39 UTC
Platform automatic detection doesn't work for some combinations of JDK and JavaFX SDK:

    32bit + 64bit JavaFX installed - run NB on 64bit JDK 7 - detection successful - OK
    32bit + 64bit JavaFX installed - run NB on 32bit JDK 7 - nothing detected - FAIL (32bit FX could be used)
    32bit + 64bit JavaFX installed - run NB on 64bit JDK 6 - nothing detected - FAIL (64bit FX could be used)
    32bit + 64bit JavaFX installed - run NB on 32bit JDK 6 - nothing detected - FAIL (32bit FX could be used)
    32bit JavaFX installed - run NB on 64bit JDK 7 - nothing detected - OK
    32bit JavaFX installed - run NB on 32bit JDK 7 - detection successful - OK
    32bit JavaFX installed - run NB on 64bit JDK 6 - nothing detected - OK
    32bit JavaFX installed - run NB on 32bit JDK 6 - nothing detected - FAIL (32bit FX could be used)
    64bit JavaFX installed - run NB on 64bit JDK 7 - detection successful - OK
    64bit JavaFX installed - run NB on 32bit JDK 7 - nothing detected - OK
    64bit JavaFX installed - run NB on 64bit JDK 6 - nothing detected - FAIL (64bit FX could be used)
    64bit JavaFX installed - run NB on 32bit JDK 6 - nothing detected - OK
Comment 1 Stepan Zebra 2011-09-23 11:34:28 UTC
After issue 202328 was resolved, the situation stabilized:

Having BOTH 32bit and 64bit FX SDK installed
 - run NB on JDK 7 64bit - OK (correctly detected)
 - run NB on JDK 7 32bit - FAIL (64bit FX detected)
 - run NB on JDK 6 64bit - OK (correctly detected)
 - run NB on JDK 6 32bit - FAIL (64bit FX detected)
Having ONLY 32bit FX SDK installed
 - run NB on JDK 7 64 - FAIL (32bit FX detected)
 - run NB on JDK 7 32 - OK (correctly detected)
 - run NB on JDK 6 64 - FAIL (32bit FX detected)
 - run NB on JDK 6 32 - OK (correctly detected)
Having ONLY 64bit FX SDK installed
 - run NB on JDK 7 64 - OK (correctly detected)
 - run NB on JDK 7 32 - FAIL (64bit FX detected)
 - run NB on JDK 6 64 - OK (correctly detected)
 - run NB on JDK 6 32 - FAIL (64bit FX detected)

So now, there are problems only in 32bit vs 64bit situations. Users, who'll install correct kits, won't run into trouble. Developers, who works with multiple kits, will be required to take manual control over when is which combination of kits used.

*** This bug has been marked as a duplicate of bug 202165 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo