Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 202165 - JavaFX Platform autodetection mixes 32 and 64 bit kits
JavaFX Platform autodetection mixes 32 and 64 bit kits
Status: RESOLVED INVALID
Product: javafx
Classification: Unclassified
Component: Platform
7.1
All All
: P3 (vote)
: 7.4
Assigned To: Petr Somol
issues@javafx
:
: 202166 202315 202750 (view as bug list)
Depends on:
Blocks: 199283
  Show dependency treegraph
 
Reported: 2011-09-15 08:52 UTC by Stepan Zebra
Modified: 2013-05-29 12:59 UTC (History)
3 users (show)

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stepan Zebra 2011-09-15 08:52:16 UTC
Product Version: NetBeans IDE Dev (Build 201109141017)
Java: 1.7.0; Java HotSpot(TM) 64-Bit Server VM 21.0-b17
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)

I experienced it in two situations:
Situation 1:
Had both 32bit and 64bit FX SDKs installed.
Started NetBeans on 32bit JDK.
Default Platform selected 32bit JDK and 64bit FX SDK.
Situation 2:
Had only 32bit FX SDK installed.
Started NetBeans on 64bit JDK.
Default Platform selected 64bit JDK and 32bit FX SDK.
Comment 1 Anton Chechel 2011-09-15 11:56:58 UTC
*** Bug 202166 has been marked as a duplicate of this bug. ***
Comment 2 Anton Chechel 2011-09-16 11:52:47 UTC
fixed, but still need to check Mac OS lib name and uncomment Utils:217
http://hg.netbeans.org/jet-main/rev/a95e8f4645bf
Comment 3 Quality Engineering 2011-09-17 14:14:51 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/a95e8f4645bf
User: Anton Chechel <manowar@netbeans.org>
Log: #202165: JavaFX Platform autodetection mixes 32 and 64 bit runtimes
Comment 4 Anton Chechel 2011-09-20 15:30:13 UTC
Reopening because of fix of http://netbeans.org/bugzilla/show_bug.cgi?id=202328

There is no good way to detect architecture of JavaFX SDK until they provide us some info explicitly.

Setting:
- Target Milestone to Next
- Priority to P3
Comment 5 Stepan Zebra 2011-09-23 11:34:28 UTC
*** Bug 202315 has been marked as a duplicate of this bug. ***
Comment 6 Stepan Zebra 2011-09-29 17:01:28 UTC
*** Bug 202750 has been marked as a duplicate of this bug. ***
Comment 7 Anton Chechel 2011-11-10 14:13:05 UTC
FX SDK should provide us this info.
Comment 8 Petr Somol 2011-11-10 14:37:28 UTC
depends on
http://javafx-jira.kenai.com/browse/RT-17796
Comment 9 Stepan Zebra 2012-05-09 11:43:52 UTC
(In reply to comment #8)
> depends on
> http://javafx-jira.kenai.com/browse/RT-17796

Issue was marked as resolved in FX 2.0.2. Any update?
Comment 10 Petr Somol 2013-05-29 12:59:00 UTC
This issue becomes irrelevant from NetBeans 7.4 onwards, as NB7.4 does not allow arbitrary mixing of FX SDKs with JDKs; now only the FX distributed as part of JDK is supported. Accordingly, there is no auto-detection, except of auto-detection inside current JDK distribution. This is made possible by the fact that FX is always distributed as part of JDK since JDK 7u6. For more info see Issue #229678.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo