Bug 202119 - Using ~ in Run Directory property leads to incorrect running directory
Using ~ in Run Directory property leads to incorrect running directory
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Project
7.0.1
All All
: P2 (vote)
: 7.1
Assigned To: igor_nikiforov
issues@cnd
CR_7093826, 701patch2-verified
:
Depends on:
Blocks: 200591
  Show dependency treegraph
 
Reported: 2011-09-14 11:14 UTC by igor_nikiforov
Modified: 2011-09-30 07:51 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description igor_nikiforov 2011-09-14 11:14:57 UTC
Test case:
1. Create Welcome project.
2. Go to Properties->Run and set ~ as Run Directory value.
3. Click ... button, and check actual run directory. In my case it is /tmp/Welcome_2/~. 

In general it will be <path-to-project>/~.
Comment 1 igor_nikiforov 2011-09-23 10:35:35 UTC
The issue is resolved here:
  http://hg.netbeans.org/cnd-main/rev/08ef498d28a7
Comment 2 igor_nikiforov 2011-09-27 13:25:23 UTC
More fixes:
  http://hg.netbeans.org/cnd-main/rev/c3672c23cd74
Comment 3 igor_nikiforov 2011-09-28 13:11:07 UTC
More fixes are here:
  http://hg.netbeans.org/cnd-main/rev/a81ce66e9ddc

Please note, that all above fixes are for local case only. The remote and full remote cases are not covered by this fix. So I've reopening this Bug.
Comment 4 igor_nikiforov 2011-09-28 13:52:29 UTC
More fixes:
  http://hg.netbeans.org/cnd-main/rev/f8b4e8c4d35b
Comment 5 igor_nikiforov 2011-09-28 13:53:00 UTC
I've checked this fix in full remote mode and it looks fine.
Comment 6 igor_nikiforov 2011-09-28 14:01:36 UTC
More fixes:
  http://hg.netbeans.org/cnd-main/rev/66c2ade7975f
Comment 7 Alexander Simon 2011-09-28 14:03:11 UTC
fix is safe and correct
Comment 8 soldatov 2011-09-29 10:51:53 UTC
verified in cnd-build-5972-on-20110928 build
Verified Solaris local case
Verified Windows->Solaris case
Comment 9 Vladimir Voskresensky 2011-09-29 10:54:28 UTC
integreated into releases/release701_fixes
http://hg.netbeans.org/releases/rev/ee295fdb10c7
Comment 10 soldatov 2011-09-30 07:51:08 UTC
verified in NetBeans IDE 7.0.1 (Build 201109292036)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo