Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 202113 - Changing path to FX SDK doesn't affect opened project
Changing path to FX SDK doesn't affect opened project
Status: RESOLVED DUPLICATE of bug 202455
Product: javafx
Classification: Unclassified
Component: Platform
7.1
PC Windows 7 x64
: P3 (vote)
: 7.1
Assigned To: Anton Chechel
issues@javafx
:
Depends on: 202455
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-14 10:04 UTC by Stepan Zebra
Modified: 2011-11-10 13:53 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stepan Zebra 2011-09-14 10:04:53 UTC
Use case:
Create FX project with FX enabled platform.
Invoke Platform Manager via main menu Tools>Java Platforms.
Change path to different FX SDK in the platform the project is using.

The change isn't propagated into the project.
This can be fixed by invoking the Project Properties dialog on the affected project and simply clicking OK in it.
Also, obviously, invoking the Platform Manager from the Project Properties dialog propagates the changes upon clicking on the OK button after making the changes.
Comment 1 Anton Chechel 2011-09-15 09:16:50 UTC
fixed
http://hg.netbeans.org/jet-main/rev/2add1cecbc09
Comment 2 Quality Engineering 2011-09-17 14:18:00 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/2add1cecbc09
User: Anton Chechel <manowar@netbeans.org>
Log: #202113: checking user input for textFields
Comment 3 Stepan Zebra 2011-09-21 15:29:24 UTC
the problem seems to be still present in 201109202329
Comment 4 Anton Chechel 2011-10-21 08:09:19 UTC
Works for me in current build.
Comment 5 Stepan Zebra 2011-10-24 11:32:08 UTC
The use case is to have a few FX projects, which are configured to use some FX platform and then globally change some paths settings in that FX platform.
By 'globally' I mean invoking the Platform Manager from main menu, do the change and close it. Project properties of any project aren't updated after this action. They are updated only after selecting the project and invoking it's Properties manager. Aren't they?
Comment 6 Anton Chechel 2011-11-10 13:53:51 UTC
This is the problem of absolute paths in project properties.

*** This bug has been marked as a duplicate of bug 202455 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo