Bug 202082 - JavaSE available but not shown as activated after activating JavaFX
JavaSE available but not shown as activated after activating JavaFX
Status: VERIFIED FIXED
Product: javafx
Classification: Unclassified
Component: Platform
7.1
All All
: P2 (vote)
: 7.1
Assigned To: Anton Chechel
issues@javafx
: ERGONOMICS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-13 16:47 UTC by Stepan Zebra
Modified: 2011-09-21 09:16 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stepan Zebra 2011-09-13 16:47:08 UTC
Product Version: NetBeans IDE Dev (Build 201109120600)
Java: 1.6.0_27; Java HotSpot(TM) Client VM 20.2-b06
System: Windows 7 version 6.1 running on x86; Cp1250; cs_CZ (nb)

Start fresh IDE and try to create a JavaFX Application. JavaFX support will be activated. I believe that at this point also whole JavaSE pack is activated.
Creating and opening JavaSE projects is working without the need of any other activation and all features seems to be present.
However if you check Tools>Plugins, JavaSE is shown as deactivated and also Java Free-Form project and Sample JavaSE projects in New Project wizard are shown as deactivated.
Also, since now, activating/deactivating JavaSE components doesn't seems to have any other effect than they are shown as activated/deactivated. No matter what state is chosen, all features are still present in the IDE.
Comment 1 Jaroslav Tulach 2011-09-15 06:24:22 UTC
Can JavaFX folks drive this? I don't even know whether JavaFX is separate feature or not.

Btw. this might be solved if bug 187678 is implemented. However I can imagine there are easier workarounds (like changing javafx.kit to depend on all kits in the java cluster).
Comment 2 Anton Chechel 2011-09-15 08:30:33 UTC
Jardo, is attached patch enough for changing javafx.kit to depend on all kits in
the java cluster?

====
diff -r 1c5bd4f58dfb nbbuild/cluster.properties
--- a/nbbuild/cluster.properties	Thu Sep 15 09:34:32 2011 +0200
+++ b/nbbuild/cluster.properties	Thu Sep 15 10:28:08 2011 +0200
@@ -1198,7 +1198,9 @@
 nb.cluster.javafx.depends=\
         nb.cluster.ide,\
         nb.cluster.platform,\
-        nb.cluster.java
+        nb.cluster.java,\
+        nb.cluster.websvccommon,\
+        nb.cluster.harness
 nb.cluster.javafx=\
         javafx2.kit,\
         javafx2.platform,\
====
Comment 3 Anton Chechel 2011-09-15 08:32:38 UTC
*** Bug 202164 has been marked as a duplicate of this bug. ***
Comment 4 Anton Chechel 2011-09-19 15:10:33 UTC
fixed
http://hg.netbeans.org/jet-main/rev/fe540215e0af
Comment 5 Quality Engineering 2011-09-21 08:08:14 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/fe540215e0af
User: Anton Chechel <manowar@netbeans.org>
Log: #202082: ergonomics magic
Comment 6 Stepan Zebra 2011-09-21 09:16:41 UTC
verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo