Bug 201916 - Doubleclicking a Java class does not transfer the focus to the editor
Doubleclicking a Java class does not transfer the focus to the editor
Status: RESOLVED DUPLICATE of bug 201823
Product: editor
Classification: Unclassified
Component: -- Other --
7.1
PC Windows XP
: P3 (vote)
: TBD
Assigned To: Milutin Kristofic
issues@editor
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-09 22:28 UTC by tkellerer
Modified: 2011-09-13 11:40 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tkellerer 2011-09-09 22:28:33 UTC
When doubleclicking a Java class in the Project window, the editor that is opened does not get the focus. When opening the class using the keyboard (hitting the ENTER key) the editor does get the focus. 

Because the editor does not get the focus, this also means the editor is not fully initialized. Code folding is not available and only basic highlighting is done which is very irritating.
Comment 1 tkellerer 2011-09-10 08:13:38 UTC
When using "Goto Source" the same thing happens (no focus in the editor, no code folding because of that). 

For "Goto Source" it doesn't matter if a shortcut (i.e keyboard only) or the context menu is used.
Comment 2 tkellerer 2011-09-10 08:14:14 UTC
Forgot to add my environment:

Product Version: NetBeans IDE Dev (Build 201109090600)
Java: 1.6.0_22; Java HotSpot(TM) Client VM 17.1-b03
System: Windows XP version 5.1 running on x86; Cp1252; en (nb)
Comment 3 Milutin Kristofic 2011-09-13 11:40:14 UTC

*** This bug has been marked as a duplicate of bug 201823 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo