Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 201872 - Automatically fix dependencies in NetBeans platform application JPanel forms
Automatically fix dependencies in NetBeans platform application JPanel forms
Status: RESOLVED DUPLICATE of bug 196497
Product: guibuilder
Classification: Unclassified
Component: Code
7.1
PC Windows 7
: P3 (vote)
: TBD
Assigned To: issues@guibuilder
issues@guibuilder
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-09 08:55 UTC by mienamoo
Modified: 2011-09-12 09:30 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mienamoo 2011-09-09 08:55:53 UTC
When creating a new JPanel form in a new NetBeans module, the developer has to manually add a module dependency and resolve imports when adding a JLabel. The text of the label will be stored in a bundle file, and accessing it requires a module dependency on the Utilities API module.

Steps to reproduce:

1. Create a new NetBeans platform application.
2. Create a new module as a part of the application from step 1.
3. Add a new JPanel form.
4. Drag and drop a label from the palette onto the form.
5. Save the form.
6. Try to build the module. You will see the following error because of unresolved dependencies:

error: package org.openide.util does not exist
jLabel1.setText(org.openide.util.NbBundle.getBundle("test/Bundle").getString("NewJPanel.jLabel1.text")); // NOI18N

Would it be possible to add the dependency on Utilities API automatically at some point during the creation process? I saw this for the very first time today since usually I would create a TopComponent first, and that wizard would add all the required dependencies. :)
Comment 1 mienamoo 2011-09-09 08:57:48 UTC
Mmm. Ignore the "resolve imports" part... After adding the dependency of course no other action is required. :)
Comment 2 Jan Stola 2011-09-12 09:30:02 UTC

*** This bug has been marked as a duplicate of bug 196497 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo