Bug 201790 - Add warning about network (FTP) connections if Java 7 is used
Add warning about network (FTP) connections if Java 7 is used
Status: RESOLVED INVALID
Product: installer
Classification: Unclassified
Component: Code
7.0.1
PC Windows 7
: P1 with 1 vote (vote)
: 7.1
Assigned To: Yulia Novozhilova
issues@installer
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-08 05:18 UTC by Tomas Mysik
Modified: 2011-09-12 09:49 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Mysik 2011-09-08 05:18:29 UTC
* This report is valid for Windows 7 as well as Windows Vista. *

Based on issue #201449, comment #18 (please, read the issue from comment #13):

----- %< -----

As correctly pointed out, this bug doesn't seem to reside in Netbeans per se,
but in Java 7.

I propose to add a message in the installer or at the first launch to add the
exception in the firewall for java.exe, as the bug [1] in the Oracle database
is currently set as low priority and also because third party firewall software
could also not trigger the appearance the exception rule wizard window.

[1] "java.net.Socket closes when "PASV" is sent on an authenticated FTP
connection" http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=7077696


----- %< -----

Please, consider adding this warning since with JDK 7, our FTP support does not work and there's no obvious way to find out what is wrong and what needs to be done.

Thanks a lot.
Comment 1 Tomas Mysik 2011-09-08 13:52:53 UTC
One note:
AFAIK, FTP is used in PHP and Mobility; the warning could be perhaps added there (but I do not prefer to have the same code on more places, moreover, if any other module will use FTP, the warning should be present there as well). But also please notice, that I'm really not sure, whether only FTP is "broken" with Java 7. For example, this link [1] shows another possible problem (could be the same as for some PHP users, they complained on PHP forum that NB won't connect to the update center).

Thanks.
[1] http://netbeans-org.1045718.n5.nabble.com/Newly-installed-NB-7-won-t-connect-to-network-td4672870.html
Comment 2 Yulia Novozhilova 2011-09-09 10:21:44 UTC
I don't think the installer is the right place for this warning. The user may install NetBeans with JDK6 and then manually change it to JDK7. In this case she never sees the warning. 
Furthermore, it is advised to switch off the firewalls while NetBeans installation [1], so it would be strange to show the message about firewall exceptions there. 

From the user point of view it would be reasonable to see the warning when the problem have place.

Adding Tonda to hear his opinion.

[1] http://netbeans.org/community/releases/70/install.html#moreinformation
Comment 3 Tomas Mysik 2011-09-09 11:04:52 UTC
(In reply to comment #2)
> I don't think the installer is the right place for this warning.

Well agreed but simply I don't know about any better place as I explained earlier.

> Furthermore, it is advised to switch off the firewalls while NetBeans
> installation [1], so it would be strange to show the message about firewall
> exceptions there. 

This warning is not about NetBeans installation but about NetBeans usage. I was just thinking about short message like:

If you use Java 7, please ensure that your firewall is properly configured.

> From the user point of view it would be reasonable to see the warning when the
> problem have place.

Well, the problem is that - for FTP - it simply fails without any way to find out the real cause (FTP client connects fine but fails e.g. for LIST command). So the only thing I can do for FTP is to show such warning (likely with checkbox "Never show this warning again" since I'm not able to find out the reason of a failure).

> Adding Tonda to hear his opinion.

Thanks, any idea is more than welcome, of course.
Comment 4 Antonin Nebuzelsky 2011-09-09 11:12:16 UTC
Agreed with Yulia. Installer is not the right place to display warnings like this. If this needs to be communicated to the users early use Release Notes for documenting that. Add RELNOTE keyword to the issue 201449 and CC docs guys.

BTW, this problem is only affecting some users. And the problem manifests by an exception which is raised and which can be easily caught in the code (e.g. PHP module) and the user can be informed about the problem there. This is the expected behavior - if something fails and the functionality knows about it (from the exception), it should tell the user.
Comment 5 Tomas Mysik 2011-09-12 09:49:20 UTC
OK, just a few notes. 

(In reply to comment #4)
> If this needs to be communicated to the users early use Release Notes for
> documenting that. Add RELNOTE keyword to the issue 201449 and CC docs guys.

Will do that but frankly, who reads Release Notes.

> And the problem manifests by an
> exception which is raised and which can be easily caught in the code (e.g. PHP
> module) and the user can be informed about the problem there. This is the
> expected behavior - if something fails and the functionality knows about it
> (from the exception), it should tell the user.

The problem is as I wrote - NB cannot find out the reason of the exception - it can be: network down, or disconnected from the server or firewall (or perhaps something else).


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo