Bug 201774 - Support for traits (PHP 5.4 feature)
Support for traits (PHP 5.4 feature)
Status: RESOLVED FIXED
Product: php
Classification: Unclassified
Component: Editor
7.1
All All
: P1 with 8 votes (vote)
: 7.2
Assigned To: Ondrej Brejla
issues@php
http://php.net/traits
:
: 206048 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-07 19:30 UTC by kross
Modified: 2012-01-12 16:10 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kross 2011-09-07 19:30:42 UTC
The upcoming PHP version 5.4 will introduce a new feature for horzontal code reuse, named traits (http://php.net/traits).

Alpha-Realease candidate is available from http://qa.php.net

Would be great to see this language feature supported by netbeans soon.
Comment 1 Petr Pisl 2011-10-31 13:43:21 UTC
Let's put it on the plan for next release.
Comment 2 lstrojny 2011-11-12 18:59:08 UTC
Next Release refers to 7.1?
Comment 3 Petr Pisl 2011-11-14 08:10:11 UTC
It will be after 7.1.
Comment 4 Ondrej Brejla 2011-12-08 08:56:55 UTC
*** Bug 206048 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo